{"added":null,"apiVersion":1,"behindSince":null,"buildDepends":[],"categories":["net"],"comment":"DHCP6 client, server and relay agent by WIDE project","compare":"/compare/wide-dhcpv6/index.json","dependentCount":null,"description":"WIDE-DHCPv6 is an open-source implementation of Dynamic Host Configuration\nProtocol for IPv6 (DHCPv6) developed by the KAME project.\n\nThe implementation mainly conforms to the following standards:\n\n- RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)\n- RFC3319: Dynamic Host Configuration Protocol (DHCPv6) Options\n\t   for Session Initiation Protocol (SIP) Servers\n- RFC3633: IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP)\n- RFC3646: DNS Configuration options for Dynamic Host\n\t   Configuration Protocol for IPv6 (DHCPv6)\n- RFC4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6\n- RFC4242: Information Refresh Time Option for Dynamic Host\n\t   Configuration Protocol for IPv6 (DHCPv6)\n\nAll the components of the main protocol are provided, i.e., DHCPv6 clients,\nservers, and relay agents. Supported message types are as follows:\n\n  Solicit, Advertise, Request, Renew, Rebind, Release, Reply,\n  Information-request, Relay-forward and Relay-reply.\n\nNote that the current implementation does not support IPv6 temporary address\nallocation by DHCPv6, and there is no plan to implement that feature at the\nmoment.","flavors":[],"html":"https://daemonports.org/netbsd/net/wide-dhcpv6/","kind":"port","lastUpdate":null,"license":["modified-bsd"],"maintainer":"pkgsrc-users@NetBSD.org","name":"wide-dhcpv6","newest":true,"newestVersion":"20080615","noVulnData":false,"origin":"net/wide-dhcpv6","otherSystems":[{"maintainer":"The OpenBSD ports mailing-list \u003cports@openbsd.org\u003e","newest":true,"noVulnData":true,"origin":"net/wide-dhcpv6","path":"/openbsd/net/wide-dhcpv6/","system":"OpenBSD","version":"20080615p10"}],"packages":[{"repo":"NetBSD 10.1 x86_64","versions":["20080615nb1"]},{"repo":"NetBSD 10.1 aarch64","versions":["20080615nb1"]},{"repo":"SmartOS / illumos x86_64","versions":["-"]},{"repo":"macOS 15 arm64","versions":["-"]}],"pkgName":"wide-dhcpv6-20080615nb1","related":null,"repository":"pkgsrc","requiredBy":[],"requiredByCount":0,"runDepends":[],"status":null,"system":"netbsd","systemLabel":"NetBSD","version":"20080615nb1","versions":null,"vulnerabilities":[{"date":"","id":"https://nvd.nist.gov/vuln/detail/CVE-2011-2717","topic":"wide-dhcpv6: shell-command-injection (CVE-2011-2717)","url":"https://nvd.nist.gov/vuln/detail/CVE-2011-2717"}],"www":"https://wide-dhcpv6.sourceforge.net/"}
