{"added":null,"apiVersion":1,"behindSince":null,"buildDepends":[],"categories":["www","python"],"comment":"Implementation of JOSE Web standards","compare":"/compare/py312-jwcrypto/index.json","dependentCount":null,"description":"An implementation of the JOSE Working Group documents:\n* RFC 7515 - JSON Web Signature (JWS)\n* RFC 7516 - JSON Web Encryption (JWE)\n* RFC 7517 - JSON Web Key (JWK)\n* RFC 7518 - JSON Web Algorithms (JWA)\n* RFC 7519 - JSON Web Token (JWT)\n* RFC 7520 - Examples of Protecting Content Using JSON Object Signing\n             and Encryption (JOSE)","flavors":[{"comment":"Implementation of JOSE Web standards","pkgName":"py312-jwcrypto-1.6.0"},{"comment":"Implementation of JOSE Web standards","pkgName":"py313-jwcrypto-1.6.0"},{"comment":"Implementation of JOSE Web standards","pkgName":"py314-jwcrypto-1.6.0"}],"html":"https://daemonports.org/netbsd/www/py-jwcrypto/","kind":"port","lastUpdate":"2026-10-07T16:27:29Z","license":["gnu-lgpl-v3"],"maintainer":"pkgsrc-users@NetBSD.org","name":"py311-jwcrypto","newest":true,"newestVersion":"1.6.0","noVulnData":false,"origin":"www/py-jwcrypto","otherSystems":[{"behindSince":"2026-08-28","maintainer":"sunpoet@FreeBSD.org","matchedBy":"name","origin":"security/py-jwcrypto","path":"/dragonfly/security/py-jwcrypto/","system":"DragonFly","version":"1.5.6"}],"packages":[{"repo":"NetBSD 10.1 x86_64","versions":["1.6.0"]},{"repo":"NetBSD 10.1 aarch64","versions":["1.6.0"]},{"repo":"SmartOS / illumos x86_64","versions":["1.6.1"]},{"repo":"macOS 15 arm64","versions":["1.6.1"]}],"pkgName":"py311-jwcrypto-1.6.0","related":null,"repository":"pkgsrc","requiredBy":["wip/py-github3.py","www/py-lti1p3","www/websockify"],"requiredByCount":3,"runDepends":["devel/py-typing-extensions","lang/python311","security/py-cryptography"],"status":null,"system":"netbsd","systemLabel":"NetBSD","version":"1.6.0","versions":[{"commit":"96cba038d8c767d72ad4f497e78f44e0e568ba28","date":"2026-10-07","version":"1.6.1"},{"commit":"3ef44e710a1936abb18a6576c02426ba2b054237","date":"2026-09-03","version":"1.6.0"},{"commit":"d87975e4919c681f794064f4f3a28eb16fe70892","date":"2026-08-28","version":"1.5.9"}],"vulnerabilities":null,"www":"https://github.com/latchset/jwcrypto"}
