BSD Ports

editors/semi 1.14.7.20240606_1 DragonFly

SEMI, Library of MIME feature for GNU Emacs for emacs

System
DragonFly
Repository
DPorts
Maintainer
[email protected] (as in FreeBSD)
License
GPLv2
Categories
editors, elisp
Package size
119.2 KiB, 596.2 KiB installed

Description

SEMI, Library of MIME feature for GNU Emacs for emacs20.

SEMI is a library to provide MIME feature for GNU Emacs. MIME is a proposed internet standard for including content and headers other than (ASCII) plain text in messages.

SEMI has the following features: - MIME message viewer (mime-view-mode) (RFC 2045 .. 2049) - MIME message composer (mime-edit-mode) (RFC 2045 .. 2049) MIME message viewer and composer also support following features: - filename handling by Content-Disposition field (RFC 1806) - PGP/MIME security Multiparts (RFC 2015) - application/pgp (draft-kazu-pgp-mime-00.txt; obsolete) - text/richtext (RFC 1521; obsolete; preview only) - text/enriched (RFC 1896) - External method configuration by mailcap (RFC 1524)

Notice that this package does not contain MIME extender for any MUAs. They are released as separated packages.

Ported by [email protected]

In the other systems

SystemPortVersion
DragonFlyeditors/semi1.14.7.20240606_1
FreeBSDeditors/semi1.14.7.20251130_1
HardenedBSDeditors/semi1.14.7.20251130_1
GhostBSDeditors/semi1.14.7.20251130_1

Install

Binary package:

pkg install semi

From DPorts:

cd /usr/dports/editors/semi && make install clean

Dependencies

Run dependencies 3

Configuration

No options to configure.

Service scripts
none
Flavors
semi-emacs_nox-1.14.7.20240606_1, semi-emacs_canna-1.14.7.20240606_1, semi-emacs_devel-1.14.7.20240606_1, semi-emacs_wayland-1.14.7.20240606_1, semi-emacs_devel_nox-1.14.7.20240606_1