net/proxy-suite 1.9.2.4_4 DragonFly
The SuSE Proxy-Suite, a set of programs to enhance firewall security
- System
- DragonFly
- Repository
- DPorts
- Maintainer
- [email protected] (as in FreeBSD)
- License
- GPLv2
- Categories
- net
- Package size
- 52.0 KiB, 113.1 KiB installed
Description
The SuSE Proxy-Suite, a set of programs to enhance firewall security. The first (and currently only) component being released is the FTP-Proxy.
* Securely relays FTP connections between clients and servers * Can switch connections from active to passive and vice versa * Utilizes port ranges for both control and data connections * Provides extensive auditing (via syslog or rotating log files) * Can separate user related from system triggered audit events * Provides command restriction based on logged in user name * Allows command argument checking with regular expressions * Is able to retrieve configuration data from an LDAP directory * Has been thoroughly tested against buffer overflow attacks * Fully conforms to RFC 959 and 1123 (the basic FTP RFCs) * Planned to support RFC 1579 ("Firewall Friendly FTP") * Planned to support RFC 2428 (IPv6 Extensions for FTP) * Based on GNU AutoConf, supposed to run on many UNIX systems
Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <[email protected]>, with updates contributed by Marius Tomaschewski <[email protected]>.
In the other systems
| System | Port | Version |
|---|---|---|
| DragonFly | net/proxy-suite | 1.9.2.4_4 |
| FreeBSD | net/proxy-suite | 1.9.2.4_4 |
Install
Binary package:
pkg install proxy-suite
From DPorts:
cd /usr/dports/net/proxy-suite && make install clean
Dependencies
No port depends on this one.
Configuration
No options to configure.
- Service scripts
- none