security/p5-Crypt-JWT 0.036 DragonFly
JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516
- System
- DragonFly
- Repository
- DPorts
- Maintainer
- [email protected] (as in FreeBSD)
- License
- ART10, GPLv1+
- Categories
- perl5, security
- Package size
- 28.1 KiB, 88.9 KiB installed
Description
JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516 implements the Perl interface to:
* JSON Web Token (JWT) * JSON Web Signature (JWS) * JSON Web Encryption (JWE)
As defined by RFC7519, RFC7515, RFC7516.
The module implements all (100%25) algorithms defined in RFC7518 - JSON Web Algorithms (JWA). This module supports Compact JWS/JWE and flattened JWS/JWE JSON serialization, general JSON serialization is not supported yet.
In the other systems
| System | Port | Version |
|---|---|---|
| DragonFly | security/p5-Crypt-JWT | 0.036 |
| FreeBSD | security/p5-Crypt-JWT | 0.038 |
| NetBSD | security/p5-Crypt-JWT | 0.038 |
| HardenedBSD | security/p5-Crypt-JWT | 0.038 |
| GhostBSD | security/p5-Crypt-JWT | 0.038 |
Install
Binary package:
pkg install p5-Crypt-JWT
From DPorts:
cd /usr/dports/security/p5-Crypt-JWT && make install clean