BSD Ports

security/py-jwcrypto 1.5.6 DragonFly

Implementation of JOSE Web standards

System
DragonFly
Repository
DPorts
Maintainer
[email protected] (as in FreeBSD)
License
LGPL3+
Categories
python, security
Package size
162.2 KiB, 1189.9 KiB installed

Description

JWCrypto provides an implementation of the JOSE Working Group documents:

  • RFC 7515 - JSON Web Signature (JWS)
  • RFC 7516 - JSON Web Encryption (JWE)
  • RFC 7517 - JSON Web Key (JWK)
  • RFC 7518 - JSON Web Algorithms (JWA)
  • RFC 7519 - JSON Web Token (JWT)
  • RFC 7520 - Examples of Protecting Content Using JSON Object Signing and Encryption (JOSE)

In the other systems

SystemPortVersion
DragonFlysecurity/py-jwcrypto1.5.6
FreeBSDsecurity/py-jwcrypto1.6.1
NetBSDwww/py-jwcrypto1.6.0
HardenedBSDsecurity/py-jwcrypto1.6.1
GhostBSDsecurity/py-jwcrypto1.6.1

Install

Binary package:

pkg install py311-jwcrypto

From DPorts:

cd /usr/dports/security/py-jwcrypto && make install clean

Dependencies

Run dependencies 3
Required by 1