BSD Ports

Artistic-1.0 9749 ports

Artistic License 1.0 · SPDX Artistic-1.0 · Read the license text at opensource.org

FreeBSD 3531 · NetBSD 1877 · DragonFly 3495 · MidnightBSD 828 · HardenedBSD 9 · GhostBSD 9 · 9749 ports in all.

PortSystemVersionComment
www/p5-Test-WWW-DeclareNetBSD0.02nb18www/p5-Test-WWW-Declare 0.02nb18: Perl 5 module for declarative testing of web app. NetBSD port maintained by [email protected].
www/p5-Test-WWW-Mechanize-CatalystNetBSD0.62nb7www/p5-Test-WWW-Mechanize-Catalyst 0.62nb7: Test::WWW::Mechanize for Catalyst. NetBSD port maintained by [email protected].
www/p5-Test-WWW-Mechanize-PSGINetBSD0.39nb7www/p5-Test-WWW-Mechanize-PSGI 0.39nb7: Perl 5 module to test PSGI programs using WWW::Mechanize. NetBSD port maintained by [email protected].
www/p5-Test2-MojoXNetBSD0.07nb1www/p5-Test2-MojoX 0.07nb1: Testing Mojo. NetBSD port maintained by [email protected].
www/p5-TwiggyNetBSD0.1026nb4www/p5-Twiggy 0.1026nb4: AnyEvent HTTP server for PSGI. NetBSD port maintained by [email protected].
www/p5-URINetBSD5.37www/p5-URI 5.37: Perl5 Uniform Resource Identifiers class (URI, RFC 2396). NetBSD port maintained by [email protected].
www/p5-URI-Escape-XSNetBSD0.14nb10www/p5-URI-Escape-XS 0.14nb10: Escape and unescape unsafe characters in URIs. NetBSD port maintained by [email protected].
www/p5-URI-FetchNetBSD0.15nb5www/p5-URI-Fetch 0.15nb5: Perl module to intelligently fetch syndication feeds. NetBSD port maintained by [email protected].
www/p5-URI-FindNetBSD20160806nb10www/p5-URI-Find 20160806nb10: Perl5 module to find URIs in arbitrary text. NetBSD port maintained by [email protected].
www/p5-URI-NestedNetBSD0.10nb13www/p5-URI-Nested 0.10nb13: Perl extension to provide nested URIs. NetBSD port maintained by [email protected].
www/p5-URI-QueryNetBSD0.16nb10www/p5-URI-Query 0.16nb10: Perl5 module providing URI query string manipulation. NetBSD port maintained by [email protected].
www/p5-URI-dbNetBSD0.22nb3www/p5-URI-db 0.22nb3: Perl extension to provide database URIs. NetBSD port maintained by [email protected].
www/p5-WWW-Amazon-WishlistNetBSD2.019nb9www/p5-WWW-Amazon-Wishlist 2.019nb9: Perl5 module to get details from your Amazon wishlist. NetBSD port maintained by [email protected].
www/p5-WWW-CSRFNetBSD1.00nb12www/p5-WWW-CSRF 1.00nb12: Generate and check tokens to protect against CSRF attacks. NetBSD port maintained by [email protected].
www/p5-WWW-Form-UrlEncodedNetBSD0.26nb7www/p5-WWW-Form-UrlEncoded 0.26nb7: Parser and builder for application/x-www-form-urlencoded. NetBSD port maintained by [email protected].
www/p5-WWW-MechanizeNetBSD2.20nb1www/p5-WWW-Mechanize 2.20nb1: Automates web page form & link interaction. NetBSD port maintained by [email protected].
www/p5-WWW-Mechanize-CachedNetBSD2.00nb1www/p5-WWW-Mechanize-Cached 2.00nb1: Cache response to be polite. NetBSD port maintained by [email protected].
www/p5-WWW-Mechanize-FormFillerNetBSD0.13nb4www/p5-WWW-Mechanize-FormFiller 0.13nb4: Framework to automate HTML forms. NetBSD port maintained by [email protected].
www/p5-WWW-Mechanize-GZipNetBSD0.14nb9www/p5-WWW-Mechanize-GZip 0.14nb9: Perl 5 module to fetch webpages with gzip-compression. NetBSD port maintained by [email protected].
www/p5-WWW-Mechanize-ShellNetBSD0.59nb8www/p5-WWW-Mechanize-Shell 0.59nb8: Interactive shell for WWW::Mechanize. NetBSD port maintained by [email protected].
www/p5-WWW-Mechanize-TimedNetBSD0.44nb15www/p5-WWW-Mechanize-Timed 0.44nb15: Perl 5 module for timing Mechanize requests. NetBSD port maintained by [email protected].
www/p5-WWW-Pastebin-PastebinCom-CreateNetBSD1.003nb12www/p5-WWW-Pastebin-PastebinCom-Create 1.003nb12: Paste to <http://pastebin.com> from Perl. NetBSD port maintained by [email protected].
www/p5-WWW-RobotRulesNetBSD6.03nb1www/p5-WWW-RobotRules 6.03nb1: Perl 5 module database of robots.txt-derived permissions. NetBSD port maintained by [email protected].
www/p5-Web-MachineNetBSD0.17nb5www/p5-Web-Machine 0.17nb5: Perl port of Webmachine. NetBSD port maintained by [email protected].
www/p5-Web-ScraperNetBSD0.38nb12www/p5-Web-Scraper 0.38nb12: Perl 5 Web Scraping Toolkit inspired by Scrapi. NetBSD port maintained by [email protected].
www/p5-WordPress-XMLRPCNetBSD2.13nb3www/p5-WordPress-XMLRPC 2.13nb3: Perl 5 API to WordPress XML-RPC services. NetBSD port maintained by [email protected].
www/p5-libwwwNetBSD6.83nb1www/p5-libwww 6.83nb1: Perl5 library for WWW access. NetBSD port maintained by [email protected].
www/parosNetBSD3.2.13nb1www/paros 3.2.13nb1: HTTP/HTTPS proxy for assessing web application vulnerabilities. NetBSD port maintained by [email protected].
x11/hot-babeNetBSD0.2.2nb49x11/hot-babe 0.2.2nb49: System load monitor. NetBSD port maintained by [email protected].
x11/p5-Alien-wxWidgetsNetBSD0.69nb36x11/p5-Alien-wxWidgets 0.69nb36: Building, finding and using wxWidgets binaries. NetBSD port maintained by [email protected].
x11/p5-ClipboardNetBSD0.26nb6x11/p5-Clipboard 0.26nb6: Copy and paste with any OS. NetBSD port maintained by [email protected].
x11/p5-Tcl-TkNetBSD1.51nb4x11/p5-Tcl-Tk 1.51nb4: Extension module for Perl giving access to Tk via the Tcl extension. NetBSD port maintained by [email protected].
x11/p5-Tcl-pTkNetBSD1.11nb4x11/p5-Tcl-pTk 1.11nb4: Interface to Tcl/Tk with Perl/Tk compatible syntax. NetBSD port maintained by [email protected].
x11/p5-TkxNetBSD1.10nb3x11/p5-Tkx 1.10nb3: Yet another Perl5 Tk interface. NetBSD port maintained by [email protected].
x11/xxkbNetBSD1.11x11/xxkb 1.11: XXKB - switches and indicates a current keyboard layout. NetBSD port maintained by [email protected].
news/cleanfeedFreeBSD20200402_1news/cleanfeed 20200402_1: Spam filter for Usenet news servers. FreeBSD port maintained by [email protected].
news/p5-News-ArticleFreeBSD1.27_4news/p5-News-Article 1.27_4: Object for handling Usenet articles in mail or news form. FreeBSD port maintained by [email protected].
news/p5-News-Article-NoCeMFreeBSD0.09news/p5-News-Article-NoCeM 0.09: Module to generate accurate NoCeM notices. FreeBSD port maintained by [email protected].
news/p5-POE-Component-Server-NNTPFreeBSD1.06news/p5-POE-Component-Server-NNTP 1.06: Component that provides NNTP server functionality. FreeBSD port maintained by [email protected].
print/latex-biberFreeBSD2.21,2print/latex-biber 2.21,2: BibTeX replacement for users of BibLaTeX. FreeBSD port maintained by [email protected].
print/p5-Net-CUPSFreeBSD0.65print/p5-Net-CUPS 0.65: Interface to the CUPS API. FreeBSD port maintained by [email protected].
print/p5-PostScript-PPDFreeBSD0.0402print/p5-PostScript-PPD 0.0402: Read PostScript Printer Definition files. FreeBSD port maintained by [email protected].
print/p5-Text-PDFFreeBSD0.31print/p5-Text-PDF 0.31: PDF manipulation module. FreeBSD port maintained by [email protected].
print/p5-XML-Handler-AxPointFreeBSD1.5print/p5-XML-Handler-AxPoint 1.5: XML Based Presentations. FreeBSD port maintained by [email protected].
science/p5-Chemistry-Bond-FindFreeBSD0.23_1science/p5-Chemistry-Bond-Find 0.23_1: Detect bonds in a molecule and assign formal bond orders. FreeBSD port maintained by [email protected].
science/p5-Chemistry-CanonicalizeFreeBSD0.11_1science/p5-Chemistry-Canonicalize 0.11_1: Number the atoms in a molecule in a unique way. FreeBSD port maintained by [email protected].
science/p5-Chemistry-MolFreeBSD0.40science/p5-Chemistry-Mol 0.40: Perl toolkit to describe molecules. FreeBSD port maintained by [email protected].
science/p5-Chemistry-ReactionFreeBSD0.02_1science/p5-Chemistry-Reaction 0.02_1: Represent a ring as a substructure of a molecule. FreeBSD port maintained by [email protected].
science/p5-Geo-CalcFreeBSD0.12science/p5-Geo-Calc 0.12: Simple geo calculator for points and distances. FreeBSD port maintained by [email protected].
science/p5-Geo-Coordinates-ConverterFreeBSD0.13_1science/p5-Geo-Coordinates-Converter 0.13_1: Simple converter of geo coordinates. FreeBSD port maintained by [email protected].
science/p5-Geo-Coordinates-Converter-iAreaFreeBSD0.14_1science/p5-Geo-Coordinates-Converter-iArea 0.14_1: Some utility functions around iArea. FreeBSD port maintained by [email protected].
science/p5-Geo-Coordinates-TransformFreeBSD0.10science/p5-Geo-Coordinates-Transform 0.10: Transform Latitude/Longitude between various different coordinate functions. FreeBSD port maintained by [email protected].
science/p5-Geo-WebService-Elevation-USGSFreeBSD0.202science/p5-Geo-WebService-Elevation-USGS 0.202: Perl extension for elevation queries against USGS web services. FreeBSD port maintained by [email protected].
security/clamtkFreeBSD6.19security/clamtk 6.19: GTK front-end for Clam Antivirus. FreeBSD port maintained by [email protected].
security/kpcliFreeBSD3.1_2security/kpcli 3.1_2: Command line interface to KeePassX and KeePass database files. FreeBSD port maintained by [email protected].
security/p5-Alt-Crypt-RSA-BigIntFreeBSD0.06security/p5-Alt-Crypt-RSA-BigInt 0.06: RSA public-key cryptosystem, using Math::BigInt. FreeBSD port maintained by [email protected].
security/p5-Apache-HtpasswdFreeBSD1.9_2security/p5-Apache-Htpasswd 1.9_2: Manage Unix crypt-style password file. FreeBSD port maintained by [email protected].
security/p5-App-GenpassFreeBSD2.401security/p5-App-Genpass 2.401: Quickly and easily create secure passwords. FreeBSD port maintained by [email protected].
security/p5-AuthCASFreeBSD1.6_2security/p5-AuthCAS 1.6_2: Perl API to Yale's Central Authentication System (CAS). FreeBSD port maintained by [email protected].
security/p5-Authen-HtpasswdFreeBSD0.171_1security/p5-Authen-Htpasswd 0.171_1: Perl interface to read and modify Apache .htpasswd files. FreeBSD port maintained by [email protected].
security/p5-Authen-Krb5-SimpleFreeBSD0.43security/p5-Authen-Krb5-Simple 0.43: User/password authentication using Kerberose 5. FreeBSD port maintained by [email protected].
security/p5-Authen-LibwrapFreeBSD0.23security/p5-Authen-Libwrap 0.23: Perl interface to TCP Wrappers library. FreeBSD port maintained by [email protected].
security/p5-Authen-NTLMFreeBSD1.09_1security/p5-Authen-NTLM 1.09_1: Perl5 NTLM authentication module. FreeBSD port maintained by [email protected].
security/p5-Authen-OATHFreeBSD1.0.0_1security/p5-Authen-OATH 1.0.0_1: OATH one time passwords implementation. FreeBSD port maintained by [email protected].
security/p5-Authen-PAMFreeBSD0.16_2security/p5-Authen-PAM 0.16_2: Perl interface to the PAM library. FreeBSD port maintained by [email protected].
security/p5-Authen-PassphraseFreeBSD0.008_2security/p5-Authen-Passphrase 0.008_2: Perl module for handling hashed passwords/passphrases as objects. FreeBSD port maintained by [email protected].
security/p5-Authen-SASLFreeBSD2.2100security/p5-Authen-SASL 2.2100: Perl5 module for SASL authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-SASL-SASLprepFreeBSD1.100security/p5-Authen-SASL-SASLprep 1.100: Stringprep Profile for User Names and Passwords (RFC 4013). FreeBSD port maintained by [email protected].
security/p5-Authen-SimpleFreeBSD0.5_1security/p5-Authen-Simple 0.5_1: Simple authentication framework. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-DBIFreeBSD0.2_1security/p5-Authen-Simple-DBI 0.2_1: Simple DBI authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-DBMFreeBSD0.2_1security/p5-Authen-Simple-DBM 0.2_1: Simple DBM authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-HTTPFreeBSD0.2_1security/p5-Authen-Simple-HTTP 0.2_1: Simple HTTP authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-LDAPFreeBSD0.3_1security/p5-Authen-Simple-LDAP 0.3_1: Simple LDAP authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-PAMFreeBSD0.2_1security/p5-Authen-Simple-PAM 0.2_1: Simple PAM authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-PasswdFreeBSD0.6_1security/p5-Authen-Simple-Passwd 0.6_1: Simple Passwd authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-RADIUSFreeBSD0.1_1security/p5-Authen-Simple-RADIUS 0.1_1: Simple RADIUS authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-SMBFreeBSD0.1_1security/p5-Authen-Simple-SMB 0.1_1: Simple SMB authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-Simple-SSHFreeBSD0.1_1security/p5-Authen-Simple-SSH 0.1_1: Simple SSH authentication. FreeBSD port maintained by [email protected].
security/p5-Authen-TacacsPlusFreeBSD0.28security/p5-Authen-TacacsPlus 0.28: Perl module that provides authentication using a tacacs+ server. FreeBSD port maintained by [email protected].
security/p5-Authen-TypeKeyFreeBSD0.05_3security/p5-Authen-TypeKey 0.05_3: TypeKey authentication verification. FreeBSD port maintained by [email protected].
security/p5-Bytes-Random-SecureFreeBSD0.29security/p5-Bytes-Random-Secure 0.29: Generate cryptographically-secure random bytes. FreeBSD port maintained by [email protected].
security/p5-CPAN-AuditFreeBSD20250829.001security/p5-CPAN-Audit 20250829.001: Audit CPAN distributions for known vulnerabilities. FreeBSD port maintained by [email protected].
security/p5-Crypt-BcryptFreeBSD0.011security/p5-Crypt-Bcrypt 0.011: Modern bcrypt implementation. FreeBSD port maintained by [email protected].
security/p5-Crypt-CAST5_PPFreeBSD1.04_1security/p5-Crypt-CAST5_PP 1.04_1: CAST5 block cipher in pure Perl. FreeBSD port maintained by [email protected].
security/p5-Crypt-Camellia_PPFreeBSD0.02_1security/p5-Crypt-Camellia_PP 0.02_1: Pure Perl Camellia 128-bit block cipher module. FreeBSD port maintained by [email protected].
security/p5-Crypt-CipherSaberFreeBSD1.01security/p5-Crypt-CipherSaber 1.01: Perl module providing an OO interface to CipherSaber encryption. FreeBSD port maintained by [email protected].
security/p5-Crypt-CracklibFreeBSD1.7_6security/p5-Crypt-Cracklib 1.7_6: Perl interface to Alec Muffet's cracklib library. FreeBSD port maintained by [email protected].
security/p5-Crypt-Curve25519FreeBSD0.08security/p5-Crypt-Curve25519 0.08: Generate shared secret using elliptic-curve Diffie-Hellman function. FreeBSD port maintained by [email protected].
security/p5-Crypt-DES_EDE3FreeBSD0.03security/p5-Crypt-DES_EDE3 0.03: Perl5 interface to a implementing 3-DES EDE encryption and decryption. FreeBSD port maintained by [email protected].
security/p5-Crypt-DHFreeBSD0.07_1security/p5-Crypt-DH 0.07_1: Perl5 interface to a Diffie-Hellman key exchange system. FreeBSD port maintained by [email protected].
security/p5-Crypt-ECBFreeBSD2.23security/p5-Crypt-ECB 2.23: Perl module implementing the ECB encryption algorithm. FreeBSD port maintained by [email protected].
security/p5-Crypt-EksblowfishFreeBSD0.009_3security/p5-Crypt-Eksblowfish 0.009_3: Perl module for the Eksblowfish block cipher. FreeBSD port maintained by [email protected].
security/p5-Crypt-FormatFreeBSD0.12security/p5-Crypt-Format 0.12: Conversion utilities for encryption applications. FreeBSD port maintained by [email protected].
security/p5-Crypt-GCryptFreeBSD1.26_3security/p5-Crypt-GCrypt 1.26_3: Perl interface to the GNU Cryptographic library. FreeBSD port maintained by [email protected].
security/p5-Crypt-GeneratePasswordFreeBSD0.05security/p5-Crypt-GeneratePassword 0.05: Generate secure random pronounceable passwords. FreeBSD port maintained by [email protected].
security/p5-Crypt-GpgMEFreeBSD0.09_2security/p5-Crypt-GpgME 0.09_2: Perl interface to libgpgme. FreeBSD port maintained by [email protected].
security/p5-Crypt-JWTFreeBSD0.038security/p5-Crypt-JWT 0.038: JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516. FreeBSD port maintained by [email protected].
security/p5-Crypt-LiteFreeBSD0.82.11_2security/p5-Crypt-Lite 0.82.11_2: Perl extension for a symmetric data encryption and decryption. FreeBSD port maintained by [email protected].
security/p5-Crypt-MySQLFreeBSD0.04_1security/p5-Crypt-MySQL 0.04_1: Perl extension to compare MySQL passwords without libmysqlclient. FreeBSD port maintained by [email protected].
security/p5-Crypt-OpenPGPFreeBSD1.19security/p5-Crypt-OpenPGP 1.19: Pure-Perl OpenPGP-compatible PGP implementation. FreeBSD port maintained by [email protected].