GPL-1.0-or-later 7429 ports
GNU General Public License v1.0 or later · SPDX GPL-1.0-or-later · Read the license text at gnu.org
FreeBSD 3423 · DragonFly 3395 · MidnightBSD 597 · HardenedBSD 7 · GhostBSD 7 · 7429 ports in all.
| Port | System | Version | Comment |
|---|---|---|---|
| lang/p5-Modern-Perl | FreeBSD | 1.20250607 | lang/p5-Modern-Perl 1.20250607: Enable all of the features of Modern Perl with one import. FreeBSD port maintained by [email protected]. |
| lang/p5-Quantum-Superpositions | FreeBSD | 2.03 | lang/p5-Quantum-Superpositions 2.03: QM-like superpositions in Perl. FreeBSD port maintained by [email protected]. |
| lang/p5-Scalar-List-Utils | FreeBSD | 1.70,1 | lang/p5-Scalar-List-Utils 1.70,1: Perl subroutines that would be nice to have in the perl core. FreeBSD port maintained by [email protected]. |
| lang/p5-Switch | FreeBSD | 2.17_1 | lang/p5-Switch 2.17_1: Switch statement for Perl. FreeBSD port maintained by [email protected]. |
| lang/p5-Tcl | FreeBSD | 1.53 | lang/p5-Tcl 1.53: Tcl extension module for Perl5. FreeBSD port maintained by [email protected]. |
| lang/p5-Test-XPath | FreeBSD | 0.20 | lang/p5-Test-XPath 0.20: Test XML and HTML content and structure with XPath expressions. FreeBSD port maintained by [email protected]. |
| lang/p5-Try-Catch | FreeBSD | 1.1.0 | lang/p5-Try-Catch 1.1.0: Try/Catch exception handler based on Try::Tiny, but faster. FreeBSD port maintained by [email protected]. |
| lang/p5-TryCatch | FreeBSD | 1.003002_1 | lang/p5-TryCatch 1.003002_1: First class try catch semantics for Perl, without source filters. FreeBSD port maintained by [email protected]. |
| lang/p5-signatures | FreeBSD | 0.14 | lang/p5-signatures 0.14: Subroutine signatures for Perl with no source filter. FreeBSD port maintained by [email protected]. |
| lang/p5-v6 | FreeBSD | 0.047 | lang/p5-v6 0.047: Experimental compiler for Perl 6. FreeBSD port maintained by [email protected]. |
| lang/perl5-devel | FreeBSD | 5.45.4 | lang/perl5-devel 5.45.4: Practical Extraction and Report Language. FreeBSD port maintained by [email protected]. |
| lang/perl5.40 | FreeBSD | 5.40.5 | lang/perl5.40 5.40.5: Practical Extraction and Report Language. FreeBSD port maintained by [email protected]. |
| lang/perl5.42 | FreeBSD | 5.42.3 | lang/perl5.42 5.42.3: Practical Extraction and Report Language. FreeBSD port maintained by [email protected]. |
| lang/perl5.44 | FreeBSD | 5.44.0 | lang/perl5.44 5.44.0: Practical Extraction and Report Language. FreeBSD port maintained by [email protected]. |
| mail/cyrus2dovecot | FreeBSD | 1.3_1 | mail/cyrus2dovecot 1.3_1: Convert Cyrus folders to Dovecot. FreeBSD port maintained by [email protected]. |
| mail/p5-Dancer-Plugin-Email | FreeBSD | 1.0400 | mail/p5-Dancer-Plugin-Email 1.0400: Simple email handling for Dancer applications. FreeBSD port maintained by [email protected]. |
| mail/p5-Dancer2-Plugin-Email | FreeBSD | 0.0202 | mail/p5-Dancer2-Plugin-Email 0.0202: Simple email handling for Dancer2 applications. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Abstract | FreeBSD | 3.010 | mail/p5-Email-Abstract 3.010: Unified interface to mail representations. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Address | FreeBSD | 1.913 | mail/p5-Email-Address 1.913: RFC 2822 Address Parsing and Creation. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Address-UseXS | FreeBSD | 1.000 | mail/p5-Email-Address-UseXS 1.000: Ensure that any code uses Email::Address::XS instead of Email::Address. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Address-XS | FreeBSD | 1.05 | mail/p5-Email-Address-XS 1.05: Parse and format RFC 2822 email addresses and groups. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Date | FreeBSD | 1.104 | mail/p5-Email-Date 1.104: Find and Format Date Headers. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Date-Format | FreeBSD | 1.008 | mail/p5-Email-Date-Format 1.008: Produce RFC 2822 date strings. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Delete | FreeBSD | 2.002 | mail/p5-Email-Delete 2.002: Delete Messages from Folders. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Filter | FreeBSD | 1.035 | mail/p5-Email-Filter 1.035: Library for creating easy email filters. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Find | FreeBSD | 0.10_1 | mail/p5-Email-Find 0.10_1: Find RFC 822 email addresses in plain text. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Folder | FreeBSD | 0.860 | mail/p5-Email-Folder 0.860: Read all the messages from a folder as Email::Simple objects. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Folder-IMAP | FreeBSD | 1.105 | mail/p5-Email-Folder-IMAP 1.105: Email::Folder Access to IMAP Folders. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Folder-IMAPS | FreeBSD | 1.105 | mail/p5-Email-Folder-IMAPS 1.105: Email::Folder access to IMAP over SSL folders. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Folder-POP3 | FreeBSD | 1.015 | mail/p5-Email-Folder-POP3 1.015: Email::Folder access to POP3 folders. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-FolderType | FreeBSD | 0.814 | mail/p5-Email-FolderType 0.814: Determine the type of a mail folder. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-FolderType-Net | FreeBSD | 1.043 | mail/p5-Email-FolderType-Net 1.043: Recognize folder types for network based message protocols. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-LocalDelivery | FreeBSD | 1.201 | mail/p5-Email-LocalDelivery 1.201: Deliver a piece of email - simply. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MIME | FreeBSD | 1.954 | mail/p5-Email-MIME 1.954: Easy MIME message parsing. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MIME-Attachment-Stripper | FreeBSD | 1.317 | mail/p5-Email-MIME-Attachment-Stripper 1.317: Strip the attachments from a mail. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MIME-ContentType | FreeBSD | 1.028 | mail/p5-Email-MIME-ContentType 1.028: Parse a MIME Content-Type Header. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MIME-Encodings | FreeBSD | 1.317 | mail/p5-Email-MIME-Encodings 1.317: Unified interface to MIME encoding and decoding. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MIME-RFC2047 | FreeBSD | 0.97 | mail/p5-Email-MIME-RFC2047 0.97: Correct handling of non-ASCII MIME headers. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-MessageID | FreeBSD | 1.408 | mail/p5-Email-MessageID 1.408: Generate world unique message-ids. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Outlook-Message | FreeBSD | 0.921 | mail/p5-Email-Outlook-Message 0.921: Read e-mail messages stored as .msg files. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Reply | FreeBSD | 1.204 | mail/p5-Email-Reply 1.204: Perl module for replying to email. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Send | FreeBSD | 2.202 | mail/p5-Email-Send 2.202: Perl module for simple email sending. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Sender | FreeBSD | 2.603 | mail/p5-Email-Sender 2.603: Library for sending email. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Sender-Transport-SQLite | FreeBSD | 1.501 | mail/p5-Email-Sender-Transport-SQLite 1.501: Deliver mail to an SQLite db for testing. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Simple | FreeBSD | 2.218 | mail/p5-Email-Simple 2.218: Simple parsing of RFC2822 message format and headers. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Simple-FromHandle | FreeBSD | 0.055 | mail/p5-Email-Simple-FromHandle 0.055: Perl library for making email objects from a filehandle. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Stuffer | FreeBSD | 0.020 | mail/p5-Email-Stuffer 0.020: More casual approach to creating and sending Email. FreeBSD port maintained by [email protected]. |
| mail/p5-Email-Valid | FreeBSD | 1.204 | mail/p5-Email-Valid 1.204: Check validity of Internet email addresses. FreeBSD port maintained by [email protected]. |
| mail/p5-LMAP-CID2SPF | FreeBSD | 0.9_2 | mail/p5-LMAP-CID2SPF 0.9_2: Module to convert between Microsoft's Caller-ID and SPF. FreeBSD port maintained by [email protected]. |
| mail/p5-MIME-Charset | FreeBSD | 1.012.2 | mail/p5-MIME-Charset 1.012.2: Charset Informations for MIME. FreeBSD port maintained by [email protected]. |
| mail/p5-MIME-EncWords | FreeBSD | 1.015.0 | mail/p5-MIME-EncWords 1.015.0: Deal with RFC 2047 encoded words (improved). FreeBSD port maintained by [email protected]. |
| mail/p5-MIME-Lite | FreeBSD | 3.033 | mail/p5-MIME-Lite 3.033: Simple interface for creating (not parsing!) MIME messages. FreeBSD port maintained by [email protected]. |
| mail/p5-MIME-Tools | FreeBSD | 5.522,2 | mail/p5-MIME-Tools 5.522,2: Set of perl5 modules for MIME. FreeBSD port maintained by [email protected]. |
| mail/p5-MIME-Types | FreeBSD | 2.29 | mail/p5-MIME-Types 2.29: Perl extension for determining MIME types. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Audit | FreeBSD | 2.228 | mail/p5-Mail-Audit 2.228: Perl module for creating easy mail filters. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-AuthenticationResults | FreeBSD | 2.20260216 | mail/p5-Mail-AuthenticationResults 2.20260216: Object Oriented Authentication-Results Headers. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-BIMI | FreeBSD | 3.20250130 | mail/p5-Mail-BIMI 3.20250130: BIMI (Brand Indicators for Message Identification) object. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Box | FreeBSD | 4.02 | mail/p5-Mail-Box 4.02: Perl module implementing a modern mail folder management. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Box-IMAP4 | FreeBSD | 4.01 | mail/p5-Mail-Box-IMAP4 4.01: Handle IMAP4 folders as client. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Box-POP3 | FreeBSD | 4.02 | mail/p5-Mail-Box-POP3 4.02: Handle POP3 folders as client. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Box-Parser-C | FreeBSD | 3.011 | mail/p5-Mail-Box-Parser-C 3.011: Parsing folders for Mail::Box with C routines. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-DKIM | FreeBSD | 1.20240923 | mail/p5-Mail-DKIM 1.20240923: Perl5 module to process and/or create DKIM email. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-DMARC | FreeBSD | 1.20260306 | mail/p5-Mail-DMARC 1.20260306: Perl5 module to process and/or create DKIM email. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-DataFeed-Abusix | FreeBSD | 2.20210112 | mail/p5-Mail-DataFeed-Abusix 2.20210112: Send SMTP transaction data to the Abusix transaction feed. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-DeliveryStatus-BounceParser | FreeBSD | 1.543 | mail/p5-Mail-DeliveryStatus-BounceParser 1.543: Perl extension to analyze bounce messages. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Field-Received | FreeBSD | 0.26_1 | mail/p5-Mail-Field-Received 0.26_1: Perl5 modules for parsing of `Received' headers in e-mails. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Freshmeat | FreeBSD | 1.20_1 | mail/p5-Mail-Freshmeat 1.20_1: Perl module to parse daily newsletters from freshmeat.net. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-IMAPClient | FreeBSD | 3.43 | mail/p5-Mail-IMAPClient 3.43: Perl5 module to talk to a IMAP4rev1 (RFC2060) server. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-IMAPTalk | FreeBSD | 4.07 | mail/p5-Mail-IMAPTalk 4.07: IMAP client interface with lots of features. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Message | FreeBSD | 4.05 | mail/p5-Mail-Message 4.05: General message object. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Milter-Authentication | FreeBSD | 4.20250811 | mail/p5-Mail-Milter-Authentication 4.20250811: Perl Mail Authentication Milter. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-OpenDKIM | FreeBSD | 4204_2 | mail/p5-Mail-OpenDKIM 4204_2: Perl interface to OpenDKIM C library. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-SRS | FreeBSD | 0.31_2 | mail/p5-Mail-SRS 0.31_2: Sender Rewriting Scheme. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-SendEasy | FreeBSD | 1.2_1 | mail/p5-Mail-SendEasy 1.2_1: Send plain/html e-mails through SMTP servers. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Sender | FreeBSD | 0.903 | mail/p5-Mail-Sender 0.903: Module for sending mails with attachments through an SMTP server. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Sendmail | FreeBSD | 0.82_1 | mail/p5-Mail-Sendmail 0.82_1: Perl module implementing a simple, platform-independent mailer. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Tools | FreeBSD | 2.22 | mail/p5-Mail-Tools 2.22: Perl5 modules for dealing with Internet e-mail messages. FreeBSD port maintained by [email protected]. |
| mail/p5-Mail-Transport | FreeBSD | 4.01 | mail/p5-Mail-Transport 4.01: Use Mail Transfer Agents (MTAs). FreeBSD port maintained by [email protected]. |
| mail/p5-Mojolicious-Plugin-Mail | FreeBSD | 1.5 | mail/p5-Mojolicious-Plugin-Mail 1.5: Mojolicious plugin to send email. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-IMAP-Client | FreeBSD | 0.9511 | mail/p5-Net-IMAP-Client 0.9511: Not so simple IMAP client library. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-IMAP-Server | FreeBSD | 1.39 | mail/p5-Net-IMAP-Server 1.39: Single-threaded multiplexing IMAP server implementation. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-IMAP-Simple | FreeBSD | 1.2212 | mail/p5-Net-IMAP-Simple 1.2212: Perl extension for simple IMAP account handling. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-IMAP-Simple-SSL | FreeBSD | 1.3_1 | mail/p5-Net-IMAP-Simple-SSL 1.3_1: SSL support for Net::IMAP::Simple. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-LMTP | FreeBSD | 0.02 | mail/p5-Net-LMTP 0.02: Local Mail Transfer Protocol Client. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-ManageSieve | FreeBSD | 0.13 | mail/p5-Net-ManageSieve 0.13: ManageSieve Protocol Client. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-POP3-XOAuth2 | FreeBSD | 0.0.2 | mail/p5-Net-POP3-XOAuth2 0.0.2: Perl extension adding SASL XOAUTH2 authentication to Net::POP3. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-SMTP-TLS | FreeBSD | 0.12_2 | mail/p5-Net-SMTP-TLS 0.12_2: SMTP client supporting TLS and AUTH. FreeBSD port maintained by [email protected]. |
| mail/p5-Net-SenderBase | FreeBSD | 1.02_1 | mail/p5-Net-SenderBase 1.02_1: Query the SenderBase service. FreeBSD port maintained by [email protected]. |
| mail/p5-POE-Component-SMTP | FreeBSD | 1.6_2 | mail/p5-POE-Component-SMTP 1.6_2: SMTP Protocol Implementation. FreeBSD port maintained by [email protected]. |
| mail/p5-Parse-MIME | FreeBSD | 1.006 | mail/p5-Parse-MIME 1.006: Perl extension to parse mime-types. FreeBSD port maintained by [email protected]. |
| mail/p5-Qmail-Envelope | FreeBSD | 0.53_1 | mail/p5-Qmail-Envelope 0.53_1: Examine and modify qmail envelope strings. FreeBSD port maintained by [email protected]. |
| mail/p5-URI-imaps | FreeBSD | 1.04 | mail/p5-URI-imaps 1.04: Support IMAPS URI. FreeBSD port maintained by [email protected]. |
| mail/p5-WWW-GMail | FreeBSD | 0.07_1 | mail/p5-WWW-GMail 0.07_1: Module that simplifies access to Gmail. FreeBSD port maintained by [email protected]. |
| math/p5-AI-DecisionTree | FreeBSD | 0.11_1 | math/p5-AI-DecisionTree 0.11_1: Perl module for Automatically Learning Decision Trees. FreeBSD port maintained by [email protected]. |
| math/p5-AI-Genetic | FreeBSD | 0.05_1 | math/p5-AI-Genetic 0.05_1: Pure Perl genetic algorithm implementation. FreeBSD port maintained by [email protected]. |
| math/p5-AI-NeuralNet-BackProp | FreeBSD | 0.89_1 | math/p5-AI-NeuralNet-BackProp 0.89_1: Perl module implementing back-propagation feed-forward neural network. FreeBSD port maintained by [email protected]. |
| math/p5-AI-Perceptron | FreeBSD | 1.0_1 | math/p5-AI-Perceptron 1.0_1: Perl module for introducing to internal operations of neural networks. FreeBSD port maintained by [email protected]. |
| math/p5-Algorithm-Combinatorics | FreeBSD | 0.27_3 | math/p5-Algorithm-Combinatorics 0.27_3: Efficient generation of combinatorial sequences. FreeBSD port maintained by [email protected]. |
| math/p5-Algorithm-CurveFit | FreeBSD | 1.06 | math/p5-Algorithm-CurveFit 1.06: Nonlinear Least Squares Fitting. FreeBSD port maintained by [email protected]. |
| math/p5-Bit-Vector | FreeBSD | 7.4_1 | math/p5-Bit-Vector 7.4_1: Library of advanced math functions that includes a Perl OO module. FreeBSD port maintained by [email protected]. |