MIT 19670 ports
MIT License · SPDX MIT · Read the license text at opensource.org
FreeBSD 7396 · NetBSD 3790 · DragonFly 5836 · MidnightBSD 2621 · HardenedBSD 7 · GhostBSD 17 · OPNsense 3 · 19670 ports in all.
| Port | System | Version | Comment |
|---|---|---|---|
| security/apg | MidnightBSD | 1.2.0_5,1 | security/apg 1.2.0_5,1: Automated Password Generator written in Go. MidnightBSD port maintained by [email protected]. |
| security/aws-lc | MidnightBSD | 1.51.2 | security/aws-lc 1.51.2: AWS libcrypto. MidnightBSD port maintained by [email protected]. |
| security/aws-vault | MidnightBSD | 6.6.2_16 | security/aws-vault 6.6.2_16: Vault for securely storing and accessing AWS credentials. MidnightBSD port maintained by [email protected]. |
| security/cargo-audit | MidnightBSD | 0.22.0_2,1 | security/cargo-audit 0.22.0_2,1: Audit Cargo.lock for crates with security vulnerabilities. MidnightBSD port maintained by [email protected]. |
| security/chroot_safe | MidnightBSD | 1.4_2 | security/chroot_safe 1.4_2: Tool to chroot softwares easily. MidnightBSD port maintained by [email protected]. |
| security/crowdsec | MidnightBSD | 1.6.3 | security/crowdsec 1.6.3: CrowdSec lightweight and collaborative security engine. MidnightBSD port maintained by [email protected]. |
| security/crowdsec-blocklist-mirror | MidnightBSD | 0.0.2_10 | security/crowdsec-blocklist-mirror 0.0.2_10: CrowdSec Blocklist Mirror. MidnightBSD port maintained by [email protected]. |
| security/crowdsec-firewall-bouncer | MidnightBSD | 0.0.28_10 | security/crowdsec-firewall-bouncer 0.0.28_10: CrowdSec bouncer written in golang for firewalls. MidnightBSD port maintained by [email protected]. |
| security/hashcat | MidnightBSD | 6.2.6_1,1 | security/hashcat 6.2.6_1,1: Advanced CPU-based password recovery utility. MidnightBSD port maintained by [email protected]. |
| security/horcrux | MidnightBSD | 0.3_1 | security/horcrux 0.3_1: Split files into encrypted fragments. MidnightBSD port maintained by [email protected]. |
| security/krb5-120 | MidnightBSD | 1.20.2 | security/krb5-120 1.20.2: MIT implementation of RFC 4120 network authentication service. MidnightBSD port maintained by [email protected]. |
| security/krb5-121 | MidnightBSD | 1.21.3 | security/krb5-121 1.21.3: MIT implementation of RFC 4120 network authentication service. MidnightBSD port maintained by [email protected]. |
| security/nebula | MidnightBSD | 1.8.2 | security/nebula 1.8.2: Scalable overlay networking tool. MidnightBSD port maintained by [email protected]. |
| security/nuclei | MidnightBSD | 3.11.1 | security/nuclei 3.11.1: Fast vulnerability scanner. MidnightBSD port maintained by [email protected]. |
| security/openssh-askpass | MidnightBSD | 1.2.4.1_2 | security/openssh-askpass 1.2.4.1_2: Graphical password applet for entering SSH passphrase. MidnightBSD port maintained by [email protected]. |
| security/py-argon2-cffi | MidnightBSD | 21.3.0_3 | security/py-argon2-cffi 21.3.0_3: Secure Argon2 password hashing algorithm. MidnightBSD port maintained by [email protected]. |
| security/py-argon2-cffi-bindings | MidnightBSD | 21.2.0_1 | security/py-argon2-cffi-bindings 21.2.0_1: Low-level CFFI bindings for Argon2. MidnightBSD port maintained by [email protected]. |
| security/py-ecdsa | MidnightBSD | 0.19.1_1 | security/py-ecdsa 0.19.1_1: ECDSA cryptographic signature library (pure python). MidnightBSD port maintained by [email protected]. |
| security/py-keyrings.alt | MidnightBSD | 4.2.0_1 | security/py-keyrings.alt 4.2.0_1: Alternate Python keyring implementations. MidnightBSD port maintained by [email protected]. |
| security/py-ntlm-auth | MidnightBSD | 1.5.0_1 | security/py-ntlm-auth 1.5.0_1: Create NTLM authentication structures. MidnightBSD port maintained by [email protected]. |
| security/py-pyotp | MidnightBSD | 2.9.0_1 | security/py-pyotp 2.9.0_1: Python One Time Password Library. MidnightBSD port maintained by [email protected]. |
| security/py-python-pam | MidnightBSD | 1.8.4_1 | security/py-python-pam 1.8.4_1: Python PAM module. MidnightBSD port maintained by [email protected]. |
| security/py-scramp | MidnightBSD | 1.4.4_1 | security/py-scramp 1.4.4_1: Pure-Python implementation of the SCRAM authentication protocol. MidnightBSD port maintained by [email protected]. |
| security/py-service-identity | MidnightBSD | 24.1.0_1 | security/py-service-identity 24.1.0_1: Service identity verification for pyOpenSSL & cryptography. MidnightBSD port maintained by [email protected]. |
| security/py-trustme | MidnightBSD | 1.1.0_1 | security/py-trustme 1.1.0_1: Top quality TLS certs while you wait, for the discerning tester. MidnightBSD port maintained by [email protected]. |
| security/py-truststore | MidnightBSD | 0.10.4_1 | security/py-truststore 0.10.4_1: Verify certificates using native system trust stores. MidnightBSD port maintained by [email protected]. |
| security/rubygem-acme-client-gitlab | MidnightBSD | 2.0.31 | security/rubygem-acme-client-gitlab 2.0.31: Client for the ACME protocol. MidnightBSD port maintained by [email protected]. |
| security/rubygem-aes_key_wrap | MidnightBSD | 1.1.0 | security/rubygem-aes_key_wrap 1.1.0: Ruby implementation of AES Key Wrap. MidnightBSD port maintained by [email protected]. |
| security/rubygem-android_key_attestation | MidnightBSD | 0.3.0 | security/rubygem-android_key_attestation 0.3.0: Android key attestation verification. MidnightBSD port maintained by [email protected]. |
| security/rubygem-attr_encrypted | MidnightBSD | 4.2.0 | security/rubygem-attr_encrypted 4.2.0: Generates attr_accessors that encrypt and decrypt attributes. MidnightBSD port maintained by [email protected]. |
| security/rubygem-bcrypt | MidnightBSD | 3.1.22 | security/rubygem-bcrypt 3.1.22: OpenBSD bcrypt password hashing algorithm. MidnightBSD port maintained by [email protected]. |
| security/rubygem-bcrypt-ruby | MidnightBSD | 3.1.5_1 | security/rubygem-bcrypt-ruby 3.1.5_1: Sophisticated and secure hash algorithm for passwords. MidnightBSD port maintained by [email protected]. |
| security/rubygem-cose | MidnightBSD | 1.2.1 | security/rubygem-cose 1.2.1: Ruby implementation of RFC 8152 CBOR Object Signing and Encryption. MidnightBSD port maintained by [email protected]. |
| security/rubygem-cvss-suite | MidnightBSD | 4.1.2 | security/rubygem-cvss-suite 4.1.2: Ruby binding to process CVSS entries. MidnightBSD port maintained by [email protected]. |
| security/rubygem-declarative_policy | MidnightBSD | 2.1.0 | security/rubygem-declarative_policy 2.1.0: Authorization framework with a declarative DSL. MidnightBSD port maintained by [email protected]. |
| security/rubygem-devise-two-factor-rails-gitlab | MidnightBSD | 5.1.0 | security/rubygem-devise-two-factor-rails-gitlab 5.1.0: Barebones two-factor authentication with Devise. MidnightBSD port maintained by [email protected]. |
| security/rubygem-digest-crc | MidnightBSD | 0.7.0 | security/rubygem-digest-crc 0.7.0: Adds support for CRC to the Digest module. MidnightBSD port maintained by [email protected]. |
| security/rubygem-doorkeeper-device_authorization_grant | MidnightBSD | 1.0.3_1 | security/rubygem-doorkeeper-device_authorization_grant 1.0.3_1: OAuth 2.0 Device Authorization Grant extension for Doorkeeper. MidnightBSD port maintained by [email protected]. |
| security/rubygem-doorkeeper-openid_connect | MidnightBSD | 1.8.11_1 | security/rubygem-doorkeeper-openid_connect 1.8.11_1: OpenID Connect extension for Doorkeeper. MidnightBSD port maintained by [email protected]. |
| security/rubygem-doorkeeper-rails-gitlab | MidnightBSD | 5.8.2 | security/rubygem-doorkeeper-rails-gitlab 5.8.2: OAuth2 provider for Rails and Grape. MidnightBSD port maintained by [email protected]. |
| security/rubygem-ed25519 | MidnightBSD | 1.4.0 | security/rubygem-ed25519 1.4.0: Ruby binding to the Ed25519 (RFC 8032). MidnightBSD port maintained by [email protected]. |
| security/rubygem-encryptor | MidnightBSD | 3.0.0 | security/rubygem-encryptor 3.0.0: Wrapper for the standard ruby OpenSSL library. MidnightBSD port maintained by [email protected]. |
| security/rubygem-gitlab-cloud-connector | MidnightBSD | 1.46.0 | security/rubygem-gitlab-cloud-connector 1.46.0: CloudConnector and lib for GitLab projects. MidnightBSD port maintained by [email protected]. |
| security/rubygem-gitlab-secret_detection | MidnightBSD | 0.40.0 | security/rubygem-gitlab-secret_detection 0.40.0: Secret detector for Gitlab. MidnightBSD port maintained by [email protected]. |
| security/rubygem-gssapi | MidnightBSD | 1.3.1 | security/rubygem-gssapi 1.3.1: FFI wrapper around the system GSSAPI library. MidnightBSD port maintained by [email protected]. |
| security/rubygem-lockbox | MidnightBSD | 1.4.1 | security/rubygem-lockbox 1.4.1: Modern encryption for Rails. MidnightBSD port maintained by [email protected]. |
| security/rubygem-net-scp | MidnightBSD | 4.1.0 | security/rubygem-net-scp 4.1.0: Non-interactive SCP processing. MidnightBSD port maintained by [email protected]. |
| security/rubygem-net-scp1 | MidnightBSD | 1.2.1 | security/rubygem-net-scp1 1.2.1: Non-interactive SCP processing. MidnightBSD port maintained by [email protected]. |
| security/rubygem-net-ssh | MidnightBSD | 7.3.0,2 | security/rubygem-net-ssh 7.3.0,2: Non-interactive SSH processing. MidnightBSD port maintained by [email protected]. |
| security/rubygem-net-ssh6 | MidnightBSD | 6.1.0 | security/rubygem-net-ssh6 6.1.0: Non-interactive SSH processing. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth | MidnightBSD | 2.1.4 | security/rubygem-omniauth 2.1.4: Generalized Rack framework for multiple-provider authentication. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-alicloud | MidnightBSD | 3.0.0_1 | security/rubygem-omniauth-alicloud 3.0.0_1: Wrapper the AliCloud Oauth2 API. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-atlassian-oauth2 | MidnightBSD | 0.2.0_3 | security/rubygem-omniauth-atlassian-oauth2 0.2.0_3: Atlassian OAuth2 strategy for OmniAuth. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-gl | MidnightBSD | 2.1.4_2 | security/rubygem-omniauth-gl 2.1.4_2: Generalized Rack framework for multiple-provider authentication. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-multipassword2 | MidnightBSD | 2.1.0 | security/rubygem-omniauth-multipassword2 2.1.0: OmniAuth strategy using different password strategies. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-oauth2-generic-gitlab | MidnightBSD | 0.2.8 | security/rubygem-omniauth-oauth2-generic-gitlab 0.2.8: Generic, Configurable OmniAuth Strategy for OAuth2 providers. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-saml-gitlab | MidnightBSD | 2.2.5 | security/rubygem-omniauth-saml-gitlab 2.2.5: OmniAuth strategy for SAML. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth-shibboleth-redux-gitlab | MidnightBSD | 2.0.0 | security/rubygem-omniauth-shibboleth-redux-gitlab 2.0.0: OmniAuth strategy for Shibboleth. MidnightBSD port maintained by [email protected]. |
| security/rubygem-omniauth1 | MidnightBSD | 1.9.2_1 | security/rubygem-omniauth1 1.9.2_1: Generalized Rack framework for multiple-provider authentication. MidnightBSD port maintained by [email protected]. |
| security/rubygem-openssl-ccm | MidnightBSD | 1.3.0_1 | security/rubygem-openssl-ccm 1.3.0_1: Implementation of RFC 3610 - Counter with CBC-MAC (CCM). MidnightBSD port maintained by [email protected]. |
| security/rubygem-openssl-cmac | MidnightBSD | 2.1.0_1 | security/rubygem-openssl-cmac 2.1.0_1: Implementation of RFC 4493, 4494, 4615 - AES-CMAC Algorithm. MidnightBSD port maintained by [email protected]. |
| security/rubygem-pyu-ruby-sasl | MidnightBSD | 0.0.3.3 | security/rubygem-pyu-ruby-sasl 0.0.3.3: Simple Authentication and Security Layer. MidnightBSD port maintained by [email protected]. |
| security/rubygem-rack-oauth2 | MidnightBSD | 2.3.0_1 | security/rubygem-rack-oauth2 2.3.0_1: OAuth 2.0 Server & Client Library. MidnightBSD port maintained by [email protected]. |
| security/rubygem-rack-oauth2-gitlab | MidnightBSD | 2.2.1_1 | security/rubygem-rack-oauth2-gitlab 2.2.1_1: OAuth 2.0 Server & Client Library. MidnightBSD port maintained by [email protected]. |
| security/rubygem-rasn1 | MidnightBSD | 0.16.3 | security/rubygem-rasn1 0.16.3: Pure ruby ASN.1 library. MidnightBSD port maintained by [email protected]. |
| security/rubygem-ruby-rc4 | MidnightBSD | 0.1.5 | security/rubygem-ruby-rc4 0.1.5: Pure Ruby implementation of the RC4 algorithm. MidnightBSD port maintained by [email protected]. |
| security/rubygem-ruby-saml-gitlab | MidnightBSD | 1.18.1 | security/rubygem-ruby-saml-gitlab 1.18.1: SAML toolkit for Ruby on Rails. MidnightBSD port maintained by [email protected]. |
| security/rubygem-safety_net_attestation | MidnightBSD | 0.5.0 | security/rubygem-safety_net_attestation 0.5.0: SafetyNet attestation response verification. MidnightBSD port maintained by [email protected]. |
| security/rubygem-ssh_data | MidnightBSD | 2.0.0 | security/rubygem-ssh_data 2.0.0: Library for parsing SSH certificates. MidnightBSD port maintained by [email protected]. |
| security/rubygem-ssrf_filter10 | MidnightBSD | 1.0.8 | security/rubygem-ssrf_filter10 1.0.8: Gem to prevent SSRF attacks. MidnightBSD port maintained by [email protected]. |
| security/rubygem-twitter_oauth | MidnightBSD | 0.4.94 | security/rubygem-twitter_oauth 0.4.94: Twitter OAuth REST API client library for Ruby. MidnightBSD port maintained by [email protected]. |
| security/rubygem-webauthn | MidnightBSD | 3.4.3 | security/rubygem-webauthn 3.4.3: WebAuthn ruby server library. MidnightBSD port maintained by [email protected]. |
| security/rustls-ffi | MidnightBSD | 0.15.3 | security/rustls-ffi 0.15.3: FFI bindings for the rustls TLS library. MidnightBSD port maintained by [email protected]. |
| security/xmlsec1 | MidnightBSD | 1.3.9_1 | security/xmlsec1 1.3.9_1: XML Security Library. MidnightBSD port maintained by [email protected]. |
| shells/antibody | MidnightBSD | 6.1.1 | shells/antibody 6.1.1: High-performance zsh plugin manager. MidnightBSD port maintained by [email protected]. |
| shells/atuin | MidnightBSD | 18.23.0 | shells/atuin 18.23.0: Magical shell history. MidnightBSD port maintained by [email protected]. |
| shells/bash-completion-zfs | MidnightBSD | 2.4.1 | shells/bash-completion-zfs 2.4.1: OpenZFS extension to the Bash completion library. MidnightBSD port maintained by [email protected]. |
| shells/carapace | MidnightBSD | 1.8.0 | shells/carapace 1.8.0: Multi-shell multi-command argument completer. MidnightBSD port maintained by [email protected]. |
| shells/envy | MidnightBSD | 0.1.0_2 | shells/envy 0.1.0_2: Shell helper that automatically sets and unsets environment variables. MidnightBSD port maintained by [email protected]. |
| shells/git-prompt.zsh | MidnightBSD | 2.4.0 | shells/git-prompt.zsh 2.4.0: Fast, customizable, pure-shell, asynchronous Git prompt for Zsh. MidnightBSD port maintained by [email protected]. |
| shells/ion | MidnightBSD | 1.0.5.1509 | shells/ion 1.0.5.1509: Modern system shell written in Rust. MidnightBSD port maintained by [email protected]. |
| shells/libpowershell-native | MidnightBSD | 7.4.0 | shells/libpowershell-native 7.4.0: Support library for PowerShell. MidnightBSD port maintained by [email protected]. |
| shells/meka | MidnightBSD | 0.66.0 | shells/meka 0.66.0: General-purpose AI agent runtime. MidnightBSD port maintained by [email protected]. |
| shells/nsh | MidnightBSD | 0.4.2 | shells/nsh 0.4.2: Command-line shell like fish, but POSIX compatible. MidnightBSD port maintained by [email protected]. |
| shells/nu_plugin_formats | MidnightBSD | 0.116.1 | shells/nu_plugin_formats 0.116.1: Nushell plugin: Support for several additional data formats. MidnightBSD port maintained by [email protected]. |
| shells/nu_plugin_gstat | MidnightBSD | 0.116.1 | shells/nu_plugin_gstat 0.116.1: Nushell plugin: Information on the status of a Git repository. MidnightBSD port maintained by [email protected]. |
| shells/nu_plugin_inc | MidnightBSD | 0.116.1 | shells/nu_plugin_inc 0.116.1: Nushell plugin: Increment a value or version. MidnightBSD port maintained by [email protected]. |
| shells/nu_plugin_polars | MidnightBSD | 0.116.1 | shells/nu_plugin_polars 0.116.1: Nushell plugin: Dataframe commands based on polars. MidnightBSD port maintained by [email protected]. |
| shells/nu_plugin_query | MidnightBSD | 0.116.1 | shells/nu_plugin_query 0.116.1: Nushell plugin: Querying SQL, XML, JSON, HTML, and WebPage Metadata. MidnightBSD port maintained by [email protected]. |
| shells/nushell | MidnightBSD | 0.82.0 | shells/nushell 0.82.0: New type of shell. MidnightBSD port maintained by [email protected]. |
| shells/ohmyzsh | MidnightBSD | 20241128 | shells/ohmyzsh 20241128: Community-driven framework for managing your zsh configuration. MidnightBSD port maintained by [email protected]. |
| shells/powershell | MidnightBSD | 7.5.5_1 | shells/powershell 7.5.5_1: Microsoft's shell with support for .NET objects. MidnightBSD port maintained by [email protected]. |
| shells/rura | MidnightBSD | 1.13.0 | shells/rura 1.13.0: Interactive TUI pipeline editor built for rapid iteration. MidnightBSD port maintained by [email protected]. |
| shells/sheldon | MidnightBSD | 0.8.5 | shells/sheldon 0.8.5: Fast, configurable, shell plugin manager. MidnightBSD port maintained by [email protected]. |
| shells/shell-hist | MidnightBSD | 0.2.0 | shells/shell-hist 0.2.0: Inspect your shell history. MidnightBSD port maintained by [email protected]. |
| shells/shellharden | MidnightBSD | 4.3.2 | shells/shellharden 4.3.2: Corrective bash syntax highlighter. MidnightBSD port maintained by [email protected]. |
| shells/zsh-antigen | MidnightBSD | 2.2.3 | shells/zsh-antigen 2.2.3: Tool for managing Zshell plugins inspired by Vundle. MidnightBSD port maintained by [email protected]. |
| shells/zsh-autosuggestions | MidnightBSD | 0.7.1 | shells/zsh-autosuggestions 0.7.1: Fish-like autosuggestions for Zsh. MidnightBSD port maintained by [email protected]. |
| shells/zsh-navigation-tools | MidnightBSD | 2.2.7 | shells/zsh-navigation-tools 2.2.7: Curses-based tools for Zshell, e.g. multi-word history searcher. MidnightBSD port maintained by [email protected]. |
| sysutils/R-cran-processx | MidnightBSD | 3.8.6 | sysutils/R-cran-processx 3.8.6: Execute and Control System Processes. MidnightBSD port maintained by [email protected]. |