net/ortp 0.25.0 MidnightBSD
Real-time Transport Protocol (RTP) library
- System
- MidnightBSD
- Repository
- mports
- Maintainer
- [email protected]
- License
- lgpl2.1
- Categories
- net
Description
oRTP - Real-time Transport Protocol library
Features:
* Written in C, works under Linux (and probably any Unix) and Windows * Implement the RFC3550 (RTP) with a easy to use API with high and low level access * Includes support for multiples profiles, AV profile (RFC3551) being the one by default * Includes a packet scheduler for to send and recv packet "on time", according to their timestamp. Scheduling is optionnal, rtp sessions can remain not scheduled * Supports mutiplexing IO, so that hundreds of RTP sessions can be scheduled by a single thread * Features an adaptive jitter algorithm for a receiver to adapt to the clockrate of the sender * Supports part of RFC2833 for telephone events over RTP * The API is well documented using doxygen * Licensed under the Lesser Gnu Public License * RTCP messages sent periodically since 0.7.0 (compound packet including sender report or receiver report + SDES) * Includes an API to parse incoming RTCP packets
In the other systems
Install
Binary package:
mport install ortp
From mports:
cd /usr/mports/net/ortp && make install clean
To depend on this port in another port's Makefile:
RUN_DEPENDS= ortp>0:net/ortp
LIB_DEPENDS= libortp.so:net/ortp
Dependencies
No port depends on this one.
Configuration
No options to configure.
- USES
- libtool pathfix pkgconfig
- Service scripts
- none
- Conflicts with
- linphone-base-[0-9]*
Files
pkg-plist 18
- include/ortp/b64.h
- include/ortp/event.h
- include/ortp/logging.h
- include/ortp/ortp.h
- include/ortp/payloadtype.h
- include/ortp/port.h
- include/ortp/rtcp.h
- include/ortp/rtp.h
- include/ortp/rtpprofile.h
- include/ortp/rtpsession.h
- include/ortp/rtpsignaltable.h
- include/ortp/sessionset.h
- include/ortp/str_utils.h
- include/ortp/telephonyevents.h
- lib/libortp.so
- lib/libortp.so.10
- lib/libortp.so.10.0.0
- libdata/pkgconfig/ortp.pc
distinfo 1
| File | Size | SHA256 |
|---|---|---|
| ortp-0.25.0.tar.gz | 565836 | 0deb826b79b1fd329f7638821d5439dc343bc55bb122daa6c90d19116cfe8d9a |
Master sites 1
- SAVANNAH/linphone/ortp/sources