converters/mimepp 1.0p1 OpenBSD
C++ class library for MIME messages
- System
- OpenBSD
- Repository
- OpenBSD ports
- Maintainer
- The OpenBSD ports mailing-list <[email protected]>
- Categories
- converters
Description
MIME++ is a C++ class library for creating, parsing, and editing messages in MIME format. The class structure in MIME++ closely follows the BNF grammar specified in RFC-822 and RFC-2045, making the library intuitive for developers who are familiar with the MIME standard. MIME++ supports quoted-printable and base64 encoding/decoding, and all header fields specified in RFC-822, RFC-1036, and RFC-2045. MIME++ is extensible through inheritance and polymorphism.
Install
Binary package:
pkg_add mimepp
From the ports tree:
cd /usr/ports/converters/mimepp && make install
Dependencies
No port depends on this one.