BSD Ports

devel/cjose 0.8.1 OpenBSD

Javascript Object Signing and Encryption library

System
OpenBSD
Repository
OpenBSD ports
Maintainer
YASUOKA Masahiko <[email protected]>
Last update
Commit
1212e2e349
Categories
devel

Description

cjose is a library implementing Javascript Object Signing and Encryption (JOSE). JOSE consists of JSON Web Signature (JWS, RFC 7515), JSON Web Encryption (JWE, RFC 7516) and JSON Web Key (JWK, RFC 7517), and is used in protocols such as OAUTH, OpenID Connect or XMPP.

In the other systems

SystemPortVersion
OpenBSDdevel/cjose0.8.1
FreeBSDdevel/cjose0.8.0.20260912
NetBSDtextproc/cjose0.6.2.6
HardenedBSDdevel/cjose0.8.0.20260912
GhostBSDdevel/cjose0.6.1_2
OPNsensedevel/cjose0.6.1_2

Install

Binary package:

pkg_add cjose

From the ports tree:

cd /usr/ports/devel/cjose && make install

Dependencies

Build dependencies 5
Run dependencies 1

No port depends on this one.

Commit history 1

DateCommitCreditsLog message
1212e2e349 sthen update to cjose-0.8.1, CVE fix pointed out by Ivo Marino, no reply from maintainer