net/walker 3.8 OpenBSD
retrieve DNS zone via DNSSEC NXT/NSEC traversal
- System
- OpenBSD
- Repository
- OpenBSD ports
- Maintainer
- The OpenBSD ports mailing-list <[email protected]>
- Categories
- net
Description
This is a proof-of-concept of a utility to download DNS zone contents even when AXFR is disabled on the server, assuming DNSSEC is used. Optionally it can also verify all digital signature RRs within a zone against the zone key. If you do not know what DNSSEC is, please refer to: RFC 2535, RFC 4033, RFC 4034, RFC 4035, "dnssec.net" (lots of DNSSEC information).
The tool supports both the old DNSSEC according to RFC 2535 (i.e., KEY/SIG) and the latest DNSSEC version according to RFC 4033 (i.e., DNSKEY/RRSIG).
In the other systems
| System | Port | Version |
|---|---|---|
| OpenBSD | net/walker | 3.8 |
| FreeBSD | dns/walker | 3.8_2 |
| NetBSD | net/walker | 3.8nb10 |
| DragonFly | dns/walker | 3.8_2 |
Install
Binary package:
pkg_add walker
From the ports tree:
cd /usr/ports/net/walker && make install
Dependencies
Run dependencies 2
No port depends on this one.