BSD Ports

security/lego 4.35.2 OpenBSD

Let's Encrypt/ACME client written in Go

System
OpenBSD
Repository
OpenBSD ports
Maintainer
Horia Racoviceanu <[email protected]>
Categories
security, lang/go

Description

Lego can be use as a Let's Encrypt/ACME CLI and can solve multiple ACME challenge types out of the box or use custom challenge solvers.

Features:

  • ACME v2 RFC 8555
    • Support RFC 8737: TLS Application-Layer Protocol Negotiation (ALPN) Challenge Extension
    • Support RFC 8738: certificates for IP addresses
    • Support RFC 9773: Renewal Information (ARI) Extension
    • Support draft-ietf-acme-profiles-00: Profiles Extension
  • Register with CA
  • Obtain certificates, both from scratch or with an existing CSR
  • Renew certificates
  • Revoke certificates
  • Robust implementation of all ACME challenges
    • HTTP (http-01)
    • DNS (dns-01)
    • TLS (tls-alpn-01)
  • SAN certificate support
  • CNAME support by default
  • Comes with multiple optional DNS providers
  • Custom challenge solvers
  • Certificate bundling
  • OCSP helper function

In the other systems

SystemPortVersion
OpenBSDsecurity/lego4.35.2
FreeBSDsecurity/lego5.5.2_2
DragonFlysecurity/lego4.22.2_2

Install

Binary package:

pkg_add lego

From the ports tree:

cd /usr/ports/security/lego && make install

Dependencies

Build dependencies 2

No port depends on this one.