BSD Ports

security/py-tlsfuzzer 20250909 OpenBSD

fuzzer and test suite for TLS implementations.

System
OpenBSD
Repository
OpenBSD ports
Maintainer
Theo Buehler <[email protected]>
Categories
security, lang/python

Description

Fuzzer and test suite for TLS implementations (SSLv2-TLSv1.3). Provides ready-to-use scripts testing for many vulnerabilities (ROBOT, DROWN, etc.) and general standards conformity (RFC 5246, RFC 7627, RFC 7905, etc.) Early alpha version - no API stability guarantees.

Install

Binary package:

pkg_add py3-tlsfuzzer

From the ports tree:

cd /usr/ports/security/py-tlsfuzzer && make install

Dependencies

Build dependencies 5
Run dependencies 3

No port depends on this one.