BSD Ports

net-mgmt/p5-Net-IPv6Addr 1.02 DragonFly

Perl extension for manipulating IPv6 addresses

System
DragonFly
Repository
DPorts
Maintainer
[email protected] (as in FreeBSD)
License
ART10, GPLv1+
Categories
net-mgmt, perl5
Package size
19.4 KiB, 47.5 KiB installed

Description

Net::IPv6Addr provides functions for parsing IPv6 addresses in all formats described by RFC1884. If Math::Base85 is installed, formats described in RFC1924 are also valid. It will generate "IP6.INT." strings (as described in RFC1886) if you are inclined to play with DNS records.

In the other systems

SystemPortVersion
DragonFlynet-mgmt/p5-Net-IPv6Addr1.02
FreeBSDnet-mgmt/p5-Net-IPv6Addr1.02
OpenBSDnet/p5-Net-IPv6Addr1.02p0
NetBSDnet/p5-Net-IPv6Addr1.02nb5
HardenedBSDnet-mgmt/p5-Net-IPv6Addr1.02
GhostBSDnet-mgmt/p5-Net-IPv6Addr1.02

Install

Binary package:

pkg install p5-Net-IPv6Addr

From DPorts:

cd /usr/dports/net-mgmt/p5-Net-IPv6Addr && make install clean

Dependencies

Run dependencies 1