BSD Ports

net/dhcp6 20080615.2_4 DragonFly

KAME DHCP6 client, server, and relay

System
DragonFly
Repository
DPorts
Maintainer
[email protected] (as in FreeBSD)
License
BSD3CLAUSE
Categories
net
Package size
112.8 KiB, 381.6 KiB installed

Description

WIDE-DHCPv6 is an open-source implementation of Dynamic Host Configuration Protocol for IPv6 (DHCPv6), originally developed by the KAME project.

The implementation mainly conforms to the following standards:

  • RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
  • RFC3319: DHCPv6 Options for Session Initiation Protocol (SIP) Servers
  • RFC3633: IPv6 Prefix Options for DHCP
  • RFC3646: DNS Configuration options for DHCPv6
  • RFC3898: Network Information Service (NIS) Configuration Options for DHCPv6
  • RFC4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6
  • RFC4242: Information Refresh Time Option for DHCPv6
  • RFC4280: DHCP Options for Broadcast and Multicast Control Servers

Note that the current implementation does not support temporary IPv6 address allocation by DHCPv6, and there is no plan to implement that feature at the moment.

In the other systems

SystemPortVersion
DragonFlynet/dhcp620080615.2_4
FreeBSDnet/dhcp620080615.2_4
MidnightBSDnet/dhcp620080615.2
HardenedBSDnet/dhcp620080615.2_4
GhostBSDnet/dhcp620080615.2_4

Install

Binary package:

pkg install dhcp6

From DPorts:

cd /usr/dports/net/dhcp6 && make install clean

Dependencies

No port depends on this one.