BSD Ports

net/dhcp6 20080615.2 MidnightBSD

KAME DHCP6 client, server, and relay

System
MidnightBSD
Repository
mports
Maintainer
[email protected]
License
bsd3
Categories
net

Description

WIDE-DHCPv6 is an open-source implementation of Dynamic Host Configuration Protocol for IPv6 (DHCPv6), originally developed by the KAME project.

The implementation mainly conforms to the following standards:

  • RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
  • RFC3319: DHCPv6 Options for Session Initiation Protocol (SIP) Servers
  • RFC3633: IPv6 Prefix Options for DHCP
  • RFC3646: DNS Configuration options for DHCPv6
  • RFC3898: Network Information Service (NIS) Configuration Options for DHCPv6
  • RFC4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6
  • RFC4242: Information Refresh Time Option for DHCPv6
  • RFC4280: DHCP Options for Broadcast and Multicast Control Servers

Note that the current implementation does not support temporary IPv6 address allocation by DHCPv6, and there is no plan to implement that feature at the moment.

In the other systems

SystemPortVersion
MidnightBSDnet/dhcp620080615.2
FreeBSDnet/dhcp620080615.2_4
DragonFlynet/dhcp620080615.2_4
HardenedBSDnet/dhcp620080615.2_4
GhostBSDnet/dhcp620080615.2_4

Install

Binary package:

mport install dhcp6

From mports:

cd /usr/mports/net/dhcp6 && make install clean

To depend on this port in another port's Makefile:

RUN_DEPENDS=	dhcp6>0:net/dhcp6

Dependencies

No port depends on this one.

Configuration

Options name: net_dhcp6

OptionDefaultDescription
DOCSoff
Service scripts
dhcp6c, dhcp6relay, dhcp6s

Files

Manual pages 6
  • dhcp6c(8)
  • dhcp6c.conf(5)
  • dhcp6ctl(8)
  • dhcp6relay(8)
  • dhcp6s(8)
  • dhcp6s.conf(5)
pkg-plist 18
  • @unexec %D/etc/rc.d/dhcp6s.sh forcestop 2>/dev/null || true
  • @unexec %D/etc/rc.d/dhcp6relay.sh forcestop 2>/dev/null || true
  • @unexec %D/etc/rc.d/dhcp6c.sh forcestop 2>/dev/null || true
  • @unexec %D/etc/rc.d/dhcp6s forcestop 2>/dev/null || true
  • @unexec %D/etc/rc.d/dhcp6relay forcestop 2>/dev/null || true
  • @unexec %D/etc/rc.d/dhcp6c forcestop 2>/dev/null || true
  • etc/dhcp6s.conf.sample
  • etc/dhcp6c.conf.sample
  • sbin/dhcp6c
  • sbin/dhcp6relay
  • sbin/dhcp6s
  • sbin/dhcp6ctl
  • share/man/man5/dhcp6c.conf.5.gz
  • share/man/man5/dhcp6s.conf.5.gz
  • share/man/man8/dhcp6c.8.gz
  • share/man/man8/dhcp6ctl.8.gz
  • share/man/man8/dhcp6relay.8.gz
  • share/man/man8/dhcp6s.8.gz
distinfo 1
FileSizeSHA256
hrs-allbsd-wide-dhcpv6-v20080615.2_GH0.tar.gz19541349c2a5135d41ca00544d60bff02866cd1b2717470c7c5247996bb58f428420c2