BSD Ports

time 233 NetBSD ports

time ports

PortVersionRepositoryComment
devel/m17n-lib1.8.0nb26pkgsrcMultilingualization library
misc/heirloom-cal070715pkgsrcCollection of standard Unix utilities (cal)
misc/heirloom-calendar070715pkgsrcCollection of standard Unix utilities (calendar)
misc/heirloom-time070715pkgsrcCollection of standard Unix utilities (time)
net/Radicale1.1.7pkgsrcCalDAV (calendar) and CardDAV (contact) server (major version 1)
net/Radicale22.1.12nb5pkgsrcCalDAV (calendar) and CardDAV (contact) server
net/ntp44.2.8p15nb4pkgsrcNetwork Time Protocol Version 4
time/R-RcppCCTZ0.2.14pkgsrc'Rcpp' Bindings for the 'CCTZ' Library
time/R-RcppDate0.0.4pkgsrc'date' C++ Header Library for Date and Time Functionality
time/R-hms1.1.3pkgsrcPretty time of day
time/R-lubridate1.9.4pkgsrcMake Dealing with Dates a Little Easier
time/R-nanotime0.3.11pkgsrcNanosecond-Resolution Time Support for R
time/R-sftime0.3.0pkgsrcClasses and Methods for Simple Feature Objects that Have a Time Column
time/R-timeDate4041.110pkgsrcChronological and calendar objects
time/R-timechange0.4.0pkgsrcEfficient Manipulation of Date-Times
time/R-tzdb0.5.0pkgsrcTime Zone Database Information
time/abclock1.0dpkgsrcAnalogue Bitmap Clock
time/anacron2.3nb3pkgsrcPeriodic command scheduler
time/asclock1.0nb2pkgsrcNeXTstep-like clock and calendar
time/asclock-gtk2.1.10nb5pkgsrcDockable clock and calendar with themes for GTK+
time/asclock-xlib2.0b11nb1pkgsrcDockable clock and calendar with themes for X11
time/bbdate0.2.4nb1pkgsrcDisplay the current date
time/cal3.5nb1pkgsrcEnhanced color version of standard calendar utility
time/calcurse4.8.2pkgsrcText based calendar and scheduling application
time/catclock0.0nb6pkgsrcVariant of the MIT xclock with a "cat" mode
time/clock-rs0.2.1pkgsrcModern, terminal-based digital clock
time/dateutils0.4.11nb11pkgsrcCommand line tools for working with dates
time/dclock4nb1pkgsrcDigital clock for X
time/ddate0.2.2pkgsrcDiscordian calendar date(1) command
time/deforaos-todo0.3.0nb21pkgsrcDeforaOS desktop todo list
time/devtodo0.1.20nb3pkgsrcDisplay and manage a list of items that are outstanding
time/fet5.25.0nb69pkgsrcAutomatically schedule timetables
time/gcal3.6.3pkgsrcGNU version of the standard calendar utility
time/gchore1.0nb64pkgsrcChore reminder tool with gtk UI
time/gkrellaclock0.3.4nb4pkgsrcNice analog clock for Gkrellm
time/gkrellm-reminder2.1.0nb4pkgsrcGKrellM plugin to remind you of events
time/glclock6.0b6.0nb7pkgsrcOpenGL-based pocket watch
time/globe20140814pkgsrcDisplay the currently-lighted face of Earth in ASCII
time/gnome-calendar40.0nb38pkgsrcCalendar application for GNOME
time/gnome-pomodoro0.17.0nb31pkgsrcPomodoro timer for Gnome
time/gnutime1.9nb1pkgsrcReport user, system, and real time used by a process
time/gnyaclock20001218nb3pkgsrcAccessory with Bezier curve
time/grdc20031019nb3pkgsrcGrand digital clock from FreeBSD-current games
time/hebcal3.11nb8pkgsrcPerpetual Hebrew calendar
time/hs-clock0.8.4nb5pkgsrcHigh-resolution clock functions: monotonic, realtime, cputime
time/hs-hourglass0.2.12nb11pkgsrcSimple performant time related library
time/hs-old-time1.1.0.4nb4pkgsrcTime library
time/hs-text-iso86010.1.1nb3pkgsrcConverting time to and from ISO 8601 text
time/hs-time-compat1.9.8nb3pkgsrcCompatibility package for time
time/hs-time-locale-compat0.1.1.5nb5pkgsrcCompatibility module for time-format locale
time/hs-time-manager0.2.2nb3pkgsrcScalable timer
time/hs-timezone-olson0.2.1nb9pkgsrcPure Haskell parser and renderer for binary Olson timezone files
time/hs-timezone-series0.1.13nb9pkgsrcEnhanced timezone handling for Data.Time
time/hs-unix-time0.4.16nb3pkgsrcUnix time parser/formatter and utilities
time/ical3.0.4nb2pkgsrcCalendar application
time/ical2rem0.5.2nb10pkgsrcConvert iCal files to remind format
time/jday2.4pkgsrcJulian date calculator
time/kcalendarcore5.116.0nb8pkgsrcKDE calendar access library
time/kcalutils26.08.0pkgsrcKDE calendar access library
time/kf6-kcalendarcore6.29.0pkgsrcKDE calendar access library
time/kf6-kholidays6.29.0pkgsrcKDE library for regional holiday information
time/khal0.14.1pkgsrcCLI calendar application built around CalDAV
time/kholidays5.116.0nb10pkgsrcKDE library for regional holiday information
time/kronolith2.3.6nb4pkgsrcHorde calendar application
time/ktimer26.08.0pkgsrcKDE countdown launcher
time/leapsunpack0.06pkgsrcCreates libtai leapsecs.dat from compressed table
time/libical3.0.20nb5pkgsrcReference implementation of the iCalendar data type and format (v3)
time/libical44.0.5nb1pkgsrcReference implementation of the iCalendar data type and format (v4)
time/lmclock1.2nb1pkgsrcHard-coded Xerox Lisp machine clock clone
time/logtime1.2nb1pkgsrcPrints date and time in a standard format
time/lua-chronos0.2.4pkgsrcHigh resolution monotonic timers for Lua
time/lua-date2.2pkgsrcDate and Time module for Lua 5.x
time/lua-tz0.4.1pkgsrcLua library for time and date manipulation
time/memo0.6nb1pkgsrcA simple memo tool written in bash
time/ntpsec1.2.4nb2pkgsrcHardened & improved NTP implementation derived from NTP Classic
time/ocaml-calendar2.04nb14pkgsrcOCaml library managing dates and times
time/ocaml-mirage-clock4.2.0nb2pkgsrcPortable clock implementation
time/ocaml-mtime1.1.0nb4pkgsrcMonotonic wall-clock time for OCaml
time/ocaml-time_now0.15.0nb2pkgsrcLibrary that reports the current time
time/ocaml-timezone0.15.0nb2pkgsrcLibrary for time zone handling
time/oclock1.0.6pkgsrcSimple analog clock to make a round window
time/p5-Business-Hours0.13nb8pkgsrcCalculate business hours in a time period
time/p5-Calendar-Simple2.1.0nb3pkgsrcPerl extension to create simple calendars
time/p5-Convert-NLS_DATE_FORMAT0.06nb10pkgsrcConvert Oracle NLS_DATE_FORMAT <-> strftime Format Strings
time/p5-Data-ICal0.24nb6pkgsrcGenerates iCalendar (RFC 2445) calendar files
time/p5-Data-ICal-DateTime0.82nb9pkgsrcConvenience methods for using Data::ICal with DateTime
time/p5-Date-Extract0.07nb4pkgsrcPerl 5 module to extract probable dates from strings
time/p5-Date-ICal2.682nb3pkgsrcPerl extension for ICalendar date objects
time/p5-Date-Leapyear1.72nb16pkgsrcIs a particular year a leap year?
time/p5-Date-Range1.41nb4pkgsrcDate::Range - deal with a range of dates
time/p5-DateTime1.6700pkgsrcPerl module for date/time sets and ranges
time/p5-DateTime-Calendar-Discordian1.0nb13pkgsrcPerl extension for the Discordian Calendar
time/p5-DateTime-Calendar-Julian0.108pkgsrcDates in the Julian calendar
time/p5-DateTime-Calendar-Mayan0.06.01nb17pkgsrcThe Mayan Long Count, Haab, and Tzolkin calendars
time/p5-DateTime-Event-Cron0.09nb10pkgsrcDateTime extension to handle crontab entries
time/p5-DateTime-Event-ICal0.13nb11pkgsrcDateTime extension for computing rfc2445 recurrences
time/p5-DateTime-Event-Random0.03nb17pkgsrcDateTime extension for creating random datetimes
time/p5-DateTime-Event-Recurrence0.19nb10pkgsrcDateTime::Set extension to create basic recurrence sets
time/p5-DateTime-Format-Builder0.8300nb6pkgsrcCreate DateTime parser classes and objects
time/p5-DateTime-Format-CLDR1.19nb9pkgsrcParse and format CLDR, Common Locale Date Repository, time patterns
time/p5-DateTime-Format-DateManip0.04nb17pkgsrcConvert Date::Manip dates and durations to/from DateTimes
time/p5-DateTime-Format-DateParse0.05nb17pkgsrcParses Date::Parse compatible formats
time/p5-DateTime-Format-Epoch0.16nb11pkgsrcConvert DateTimes to/from epoch seconds
time/p5-DateTime-Format-Flexible0.37nb2pkgsrcFlexibly parse strings and turn them into DateTime objects
time/p5-DateTime-Format-HTTP0.43nb2pkgsrcDeal with date formats used by HTTP
time/p5-DateTime-Format-ICal0.09nb18pkgsrcParse and format iCal datetime and duration strings
time/p5-DateTime-Format-ISO86010.1900nb1pkgsrcParses ISO8601 formats
time/p5-DateTime-Format-Mail0.4030nb10pkgsrcConvert between DateTime and RFC2822/822 formats
time/p5-DateTime-Format-MySQL0.08nb3pkgsrcParse and format MySQL dates and times
time/p5-DateTime-Format-Natural1.27pkgsrcCreate machine readable date/time with natural parsing logic
time/p5-DateTime-Format-Oracle0.06nb13pkgsrcParse and format Oracle dates and timestamps
time/p5-DateTime-Format-Pg0.16014nb6pkgsrcParse and format PostgreSQL dates and times
time/p5-DateTime-Format-SQLite0.11nb17pkgsrcParse and format SQLite dates and times
time/p5-DateTime-Format-Strptime1.8000nb1pkgsrcPerl 5 module to parse and format strp and strf time patterns
time/p5-DateTime-Format-W3CDTF0.08nb5pkgsrcConvert between DateTime and W3CDTF date/time format
time/p5-DateTime-HiRes0.04nb4pkgsrcCreate DateTime objects with sub-second current time resolution
time/p5-DateTime-Incomplete0.08nb10pkgsrcDateTime::Incomplete - An incomplete datetime, like January 5
time/p5-DateTime-Locale1.46pkgsrcLocalization data for p5-DateTime
time/p5-DateTime-Precise1.05nb18pkgsrcPerl module for common time and date operations with GPS ops
time/p5-DateTime-Set0.3900nb10pkgsrcPerl module for date/time sets and ranges
time/p5-DateTime-TimeZone2.69nb1pkgsrcPerl module to handle time zone manipulation
time/p5-DateTimeX-Easy0.092nb2pkgsrcParse a date/time string using the best method available
time/p5-POSIX-strftime-Compiler0.46nb3pkgsrcPerl extension for glibc compatible strftime for loggers/servers
time/p5-Rose-DateTime0.540nb13pkgsrcDateTime helper functions and objects for Rose
time/p5-Schedule-At1.15nb12pkgsrcOS independent interface to the Unix 'at' command
time/p5-Schedule-Cron-Events1.96nb6pkgsrcPerl module to find when crontab events will occur
time/p5-Test-MockTime0.17nb9pkgsrcReplaces actual time with simulated time
time/p5-Test-MockTime-HiRes0.08nb4pkgsrcReplaces actual time with simulated high resolution time
time/p5-Test-Time0.092nb4pkgsrcOverride time()/sleep() core functions for testing
time/p5-Time-Clock1.03nb12pkgsrcTwenty-four hour clock object with nanosecond precision
time/p5-Time-Duration1.21nb8pkgsrcPerl5 module for rounded or exact English expression of durations
time/p5-Time-Duration-Parse0.16nb5pkgsrcPerl5 module to parse string that represents time duration
time/p5-Time-Elapsed0.33nb8pkgsrcDisplays the elapsed time as a human readable string
time/p5-Time-Format1.16nb6pkgsrcEasy-to-use date/time formatting
time/p5-Time-Format_XS1.03nb17pkgsrcCompanion module for Time::Format, to speed up time formatting
time/p5-Time-Interval1.234nb9pkgsrcConverts time intervals of days, hours, minutes, and seconds
time/p5-Time-Period1.20nb20pkgsrcPerl5 module to deal with time periods
time/p5-Time-Progress2.14nb3pkgsrcElapsed and estimated finish time reporting
time/p5-Time-TAI642.11nb19pkgsrcConvert TAI64 strings into standard unix timestamps
time/p5-Time-Warp0.55nb4pkgsrcPerl 5 module to control the flow of time
time/p5-Time-modules2013.0912nb12pkgsrcMiscellaneous date parsing and formatting
time/p5-TimeDate2.35nb1pkgsrcPerl5 TimeDate distribution
time/pcal4.11.0pkgsrcPostScript calendar program
time/pclock0.13.1nb2pkgsrcSimple analog clock designed for Window Maker
time/pear-Date1.5.0a4nb1pkgsrcPHP Date and Time Zone Classes
time/phoon20050629pkgsrcShow phase of the moon on ASCII terminal
time/php-calendar5.6.40nb1pkgsrcPHP extension for calendar conversion support
time/php-mrbs1.11.6nb1pkgsrcMeeting Room Booking System
time/plan1.12nb1pkgsrcSchedule planner based on X/Motif
time/plasma6-knighttime6.7.4pkgsrcHelpers for scheduling the dark-light cycle
time/polclock1.11nb2pkgsrcDigital clock with some nice graphics effects
time/projectlibre1.9.3pkgsrcProject management software
time/py-aniso860110.0.1pkgsrcLibrary for parsing ISO 8601 strings
time/py-arrow1.4.0pkgsrcBetter dates and times for Python
time/py-cftime1.6.5pkgsrcTime-handling functionality
time/py-ciso86012.3.3pkgsrcFast ISO8601 date time parser for Python written in C
time/py-croniter6.2.4pkgsrcIteration for datetime object with cron like format
time/py-dateparser1.4.3pkgsrcDate parsing library designed to parse dates from HTML pages
time/py-dateutil2.9.0.0.0.0nb3pkgsrcExtensions to the standard datetime module
time/py-durationpy0.11pkgsrcConverting between datetime.timedelta and Go's Duration
time/py-goocalendar0.8.0nb10pkgsrcCalendar widget using GooCanvas
time/py-icalendar7.3.0pkgsrcPython parser/generator for iCalendar files, as per RFC2445
time/py-iso86012.1.0nb2pkgsrcSimple Python module to parse ISO 8601 dates
time/py-isodate0.7.2nb1pkgsrcISO 8601 date/time/duration parser and formatter
time/py-jdcal1.4.1nb3pkgsrcJulian dates from proleptic Gregorian and Julian calendars
time/py-jinja2-time0.2.0nb2pkgsrcJinja2 extention for dates and times
time/py-jrnl4.2.1nb1pkgsrcCommand line journal application
time/py-juliandate1.0.5nb1pkgsrcPython module for Julian date conversions
time/py-l18n2021.3pkgsrcTranslations for pytz names
time/py-ligotimegps2.1.0pkgsrcPure-python version of lal.LIGOTimeGPS
time/py-mxDateTime3.2.9nb1pkgsrcPython extension that provides types and conversions for dates
time/py-parsedatetime2.6nb2pkgsrcPython module for parsing human-readable date/time text
time/py-pytimeparse1.1.8nb1pkgsrcTime expression parser
time/py-pytz2026.3.0.1pkgsrcWorld timezone definitions, modern and historical
time/py-pytz_deprecation_shim0.1.0.0nb2pkgsrcShims to make deprecation of pytz easier
time/py-relativetimebuilder3.0.3pkgsrcDateutil relativedeltas for calendar precision with aniso8601
time/py-rfc33392.1.0pkgsrcLibrary for generating and parsing RFC 3339-compliant timestamps
time/py-rfc3339-validator0.1.4nb2pkgsrcPure Python RFC3339 validator
time/py-snaptime0.2.4nb1pkgsrcTransform timestamps with a simple DSL
time/py-strict-rfc33390.7nb1pkgsrcStrict, simple, lightweight RFC3339 functions
time/py-tempora5.12.0pkgsrcObjects and routines pertaining to date and time
time/py-time-machine3.5.1pkgsrcTravel through time in your tests
time/py-timelib0.3.0pkgsrcParse English textual date descriptions
time/py-trading-calendars2.1.1nb1pkgsrcSecurities exchange calendars used by Zipline
time/py-types-python-dateutil2.9.0.20260807pkgsrcTyping stubs for python-dateutil
time/py-tzdata2026.4pkgsrcProvider of IANA time zone data
time/py-tzlocal5.4.4pkgsrcPython tzinfo object for the local timezone
time/py-vdirsyncer0.21.0pkgsrcSynchronization tool for vdir
time/rclock2.7.10pkgsrcAnalog clock for X w/appointment reminder and mail notification
time/rem2ics0.93nb12pkgsrcConvert remind output into RFC2445 iCalendar format
time/remind3.2.0nb3pkgsrcCalendar/alarm program with interpreted input language
time/rsclock0.1.12pkgsrcSimple terminal clock
time/rsibreak0.12.15nb17pkgsrcRSI management tool
time/ruby-hitimes3.2.0pkgsrcFast, high resolution timer library
time/ruby-iso86010.13.0pkgsrcRuby parser to work with ISO 8601 dateTimes and durations
time/ruby-timers4.4.0pkgsrcPure Ruby one-shot and periodic timers
time/ruby-tzinfo2.0.6pkgsrcDaylight savings aware timezone library
time/ruby-tzinfo-data1.2026.4pkgsrcDaylight-savings-aware timezone library data
time/ruby-tzinfo11.2.11pkgsrcDaylight savings aware timezone library
time/rusti-cal1.1.0pkgsrcMinimal calendar command line
time/saturn-cli0.4.5pkgsrcCalendar for CLI nerds
time/saytime20150127nb1pkgsrcTalking clock
time/sunclock3.57nb1pkgsrcShow which portion of the Earth's surface is illuminated by the Sun
time/swisswatch0.06nb2pkgsrcSwiss railway clock emulation, and a fancy default appearance
time/taskwarrior2.6.2nb12pkgsrcOpen source, command-line, TODO list manager
time/tdl1.5.2nb1pkgsrcTodo list manager with tons of features
time/titrax1.98nb18pkgsrcLittle X11 tool to track project times
time/todotxt2.12.0pkgsrcSimple and extensible shell script for managing your todo.txt file
time/tty-clock2.3pkgsrcSimple console clock
time/tzdiff1.2.1pkgsrcShowing time pairs between target timezone and localtime
time/uair0.6.2pkgsrcExtensible pomodoro timer
time/vixie-cron4.1nb2pkgsrcExecute and maintain scheduled commands
time/wmCalClock1.25nb2pkgsrcAnother WindowMaker calendar/clock dockapp
time/wmclockmon0.8.1nb2pkgsrcWindowmaker dockapp for time/date
time/wmfishtime1.24nb2pkgsrcDockable clock application with clock, date and fish
time/wmitime0.5nb1pkgsrcWindowmaker dockapp for time/date/itime
time/wmmoonclock1.30pkgsrcShows lunar ephemeris to fairly high accuracy
time/wmtime1.4pkgsrcTime/Date applet for WindowMaker
time/wmzcalock0.1nb1pkgsrcDockapp calendar clock
time/xalarm3.06nb5pkgsrcX11 interactive alarm clock
time/xbeats0.4nb2pkgsrcBeats clock dockable in both Window Maker and AfterStep
time/xchrono19900813nb2pkgsrcMulti-timezone X11-based clock
time/xclock1.2.1pkgsrcAnalog / digital clock for X
time/xdaliclock2.44pkgsrcAnimated digital clock
time/xdiary3.0.3nb2pkgsrcCalendar utility based on Motif/X
time/xdkcal0.9dnb1pkgsrcX Desktop Calendar
time/xfce4-orage4.20.1nb8pkgsrcXfce time managing application
time/xfce4-timer-plugin1.7.3nb6pkgsrcXfce4 timer plugin
time/xonclock0.0.9.4nb15pkgsrcAnalog clock
time/xtide2.15.2pkgsrcX11 tide predictor
time/xtimer0.8089nb4pkgsrcSuper simple digital timer for X11
time/xtu1.3pkgsrcSmall configurable X11 analog clock
time/zonetab0pkgsrcNetBSD zone.tab file