BSD Ports

wip/semi 1.14.6nb10 NetBSD

Emacs lisp library to provide MIME feature

System
NetBSD
Repository
pkgsrc-wip
Maintainer
[email protected]
Last update
Commit
c6e5fcdccd
License
gnu-gpl-v2 OR gnu-gpl-v3
Categories
wip, devel

Description

(github version of SEMI) SEMI is a library to provide MIME feature for GNU Emacs. MIME is a proposed internet standard for including content and headers other than (ASCII) plain text in messages. RFC 2045 : Internet Message Bodies RFC 2046 : Media Types RFC 2047 : Message Header Extensions RFC 2048 : MIME Registration Procedures RFC 2049 : MIME Conformance SEMI has the following features: - MIME message viewer (mime-view-mode) (RFC 2045 .. 2049) - MIME message composer (mime-edit-mode) (RFC 2045 .. 2049) MIME message viewer and composer also support following features: - filename handling by Content-Disposition field (RFC 1806) - PGP/MIME security Multiparts (RFC 2015) - application/pgp (draft-kazu-pgp-mime-00.txt; obsolete) - text/richtext (RFC 1521; obsolete; preview only) - text/enriched (RFC 1896) - External method configuration by mailcap (RFC 1524)

In the other systems

SystemPortVersion
NetBSDwip/semi1.14.6nb10
FreeBSDeditors/semi1.14.7.20251130_1
DragonFlyeditors/semi1.14.7.20240606_1
HardenedBSDeditors/semi1.14.7.20251130_1
GhostBSDeditors/semi1.14.7.20251130_1

Install

From pkgsrc-wip (no binary package):

cd /usr/pkgsrc/wip/semi && make install clean

Dependencies

Build dependencies 1
Run dependencies 2

No port depends on this one.

Commit history 3

DateCommitCreditsLog message
c6e5fcdccd Thomas Klausner semi: fix download
a2823f9e14 Makoto Fujiwara (devel/semi) UNBROKEN, set WRKSRC
90cf8c54ad Thomas Klausner *: adapt emacs packages to new framework