BSD Ports

mail/p5-Email-Address-XS 1.05 OpenBSD

parse and format RFC 5322 email addresses and groups

System
OpenBSD
Repository
OpenBSD ports
Maintainer
The OpenBSD ports mailing-list <[email protected]>
Categories
mail, perl5

Description

This module implements RFC 5322 parser and formatter of email addresses and groups. It parses an input string from email headers which contain a list of email addresses or a groups of email addresses (like From, To, Cc, Bcc, Reply-To, Sender, ...). Also it can generate a string value for those headers from a list of email addresses objects. Module is backward compatible with RFC 2822 and RFC 822.

Parser and formatter functionality is implemented in XS and uses shared code from Dovecot IMAP server.

It is a drop-in replacement for the Email::Address module which has several denial-of-service issues. Most existing applications can be switched by replacing every "Email::Address" occurrence with "Email::Address::XS".

In the other systems

SystemPortVersion
OpenBSDmail/p5-Email-Address-XS1.05
FreeBSDmail/p5-Email-Address-XS1.05
NetBSDmail/p5-Email-Address-XS1.05nb4
DragonFlymail/p5-Email-Address-XS1.05
MidnightBSDmail/p5-Email-Address-XS1.05
HardenedBSDmail/p5-Email-Address-XS1.05
GhostBSDmail/p5-Email-Address-XS1.05

Install

Binary package:

pkg_add p5-Email-Address-XS

From the ports tree:

cd /usr/ports/mail/p5-Email-Address-XS && make install

Dependencies