mail/py-dkimpy 1.1.8p1 OpenBSD
a library and tool that implements DKIM/ARC
- System
- OpenBSD
- Repository
- OpenBSD ports
- Maintainer
- Kirill A. Korinsky <[email protected]>
- Categories
- mail, lang/python
Description
Python module and CLI tool that implements DKIM (DomainKeys Identified Mail) email signing and verification (RFC6376). It also provides helper scripts for command line signing and verification. As of 0.7.0 it supports DKIM signing/verifying of ed25519-sha256 signatures (RFC 8463). As of version 0.9.0, it also supports the RFC 8617 Authenticated Received Chain (ARC) protocol.
In the other systems
| System | Port | Version |
|---|---|---|
| OpenBSD | mail/py-dkimpy | 1.1.8p1 |
| FreeBSD | mail/py-dkimpy | 1.1.8_3 |
| DragonFly | mail/py-dkimpy | 1.1.8_1 |
| MidnightBSD | mail/py-dkimpy | 1.1.8 |
| HardenedBSD | mail/py-dkimpy | 1.1.8_3 |
| GhostBSD | mail/py-dkimpy | 1.1.8_3 |
Install
Binary package:
pkg_add py3-dkimpy
From the ports tree:
cd /usr/ports/mail/py-dkimpy && make install
Dependencies
Build dependencies 5
Run dependencies 5
No port depends on this one.